Results 1 to 2 of 2
  1. #1

    Join Date
    Jan 2006
    Patterson La

    01 sxi bogging after stator replacement

    I replaced the stator because the front seal came apart and shorted it out. I used a new stator from SBT. Now the engine boggs and runs like its hitting the rev limiter at 3000 or 4000 rpms. I've seen this happen before, and it was a bad CDI. What do I need to look for?


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    North Central Arkansas
    I would automatically suspect the SBT stator. Get me the A/C voltage output from the pickup, excitor, and charge coil and I'll tell you if it's OK. I've not had any luck at all with the SBT stators.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help - 2003 Gen DI problems after stator replace
    By mononc in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-03-2013, 08:48 PM
  2. Update on 96 XP800 Stator Replacement
    By Schwarzenegger in forum 2-Stroke Performance
    Replies: 7
    Last Post: 02-19-2009, 10:25 PM
  3. Help with bogging after rebuild.
    By SideFX in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-02-2008, 01:13 AM
  4. Stator Replacement/Manual Domestic Engine
    By heavyd65 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-25-2007, 11:34 AM
  5. 1994 slt stator replacement
    By tallyhoe in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-14-2007, 11:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts