Results 1 to 9 of 9
  1. #1

    Join Date
    Feb 2015
    Location
    Mandurah, Western Australia
    Posts
    12
    +1
    1

    Seadoo Wake Pro Power failure

    Hi guys I was riding my seadoo the other day when it lost all power and started making a really horrid screeching sound, the ski its self has done 106 hours and has done only an hour since a full supercharger rebuild. I had just put it into sport mode and took it out of fuel saver mode and within 20 seconds of that happening is when the screeching started. Has anyone experienced this or does anyone have any possible causes?

    Cheers Mic


  2. #2
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    We will likely need more information. Where was the sound coming from?

  3. #3

    Join Date
    Feb 2015
    Location
    Mandurah, Western Australia
    Posts
    12
    +1
    1
    sounded like from the rear of the ski, I was going about 100km/h when it dropped to 20-30km/h. although once I got home and put it on the hose the sound was gone.

  4. #4
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    That sounds to me like it could be intake related. Did you inspect for debris?

  5. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,066
    +1
    790
    Who did the rebuild? I would suspect the rebuild... Bearings forced in and messed the cage up droped the bearings and the impeller touched down.

  6. #6

    Join Date
    Feb 2015
    Location
    Mandurah, Western Australia
    Posts
    12
    +1
    1
    I pulled the air intake off the so I could look down the back of the engine bay but everything looked intact and I had a glance around the impeller but cant see anything without pulling it apart. is there anywhere else I should look for damage?
    Last edited by mic1623; 02-10-2015 at 01:13 AM.

  7. #7

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    pull the charger to get a better look.

  8. #8

    Join Date
    Feb 2015
    Location
    Mandurah, Western Australia
    Posts
    12
    +1
    1
    I've sent a video off to a guy in perth and he thinks it's the pump bearing

  9. #9
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Sounds like the Jet pump...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Seadoo Wake Pro Genuine Seadoo Cover
    By Bangorman in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-17-2015, 05:44 AM
  2. Seadoo wake pro bellow and bearing replacment
    By mic1623 in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-14-2015, 12:09 PM
  3. Replies: 27
    Last Post: 03-09-2015, 05:31 PM
  4. Replies: 2
    Last Post: 03-28-2014, 11:51 AM
  5. Seadoo wake pro 215 good boat ?
    By [email protected] in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-25-2008, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •