Results 1 to 9 of 9
  1. #1
    javo's Avatar
    Join Date
    Jan 2015
    Location
    Atlanta, GA
    Posts
    124
    +1
    16

    Water Temp on instrument panel.

    Hey guys, find time rider here. Took my ski out last weekend with CCW and he asked me if i could see the water temp on the control panel. Well i told him no, bc it was not coming up. I have a 2014 RXT-260 and i thought it came with the water temp sensor. Can anyone confirm or deny if the ski has it and if it does why isn't it working?

    Thanks for your help guys!!!

    Javo


  2. #2
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,134
    +1
    821
    Should be able to press mode button until display comes up, then use up and down arrows to scroll to temp, then select set. You should be able to scroll through several dash display options.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I don't think Seadoo puts lake temp sensors on any skis anymore, except for maybe the GTX's

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Javo, when you went to get your 4Runner and I was on your ski, I ran through all the functions and didn't find it.

  5. #5
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,134
    +1
    821
    Ah, sorry. I was thinking engine temp.

  6. #6
    Tbranella's Avatar
    Join Date
    Feb 2013
    Location
    Galloway Twp. NJ
    Posts
    571
    +1
    71
    the only model that gets the lake water temp now is the GTX Limited iS 260...
    I miss it..

  7. +1 by:


  8. #7
    javo's Avatar
    Join Date
    Jan 2015
    Location
    Atlanta, GA
    Posts
    124
    +1
    16
    ahhh, ok guys. I kinda wanted to have that option. Would have been cool. Thanks for your help and info!!!!

    Javo

  9. #8
    javo's Avatar
    Join Date
    Jan 2015
    Location
    Atlanta, GA
    Posts
    124
    +1
    16
    Quote Originally Posted by CCW View Post
    Javo, when you went to get your 4Runner and I was on your ski, I ran through all the functions and didn't find it.
    We have to go again man, maybe we can check out another lake some where. Let me know.

  10. #9
    Anyone found a way to get the water temp sensor back on the 2014 models I really miss that water temp feature

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha GP1200R problem with no Spark and water temp light comes on?
    By Quottro in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-26-2015, 05:04 AM
  2. Water Temp on a 2012 GTR
    By terrymcg in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-27-2014, 03:12 PM
  3. Engine / Water Temp on 2007 STX 12F
    By vwmikey99 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-03-2012, 06:46 AM
  4. Cracked Water Tube on Polaris Virage, Temp Fix?
    By JBoever in forum Polaris Open Discussion
    Replies: 11
    Last Post: 05-31-2011, 08:03 AM
  5. Yamaha GP1200R no spark with water temp diplay on the gauge? Gauge or sensor?
    By Quottro in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-20-2011, 07:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •