Results 1 to 6 of 6
  1. #1
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790

    VTS Function FiX GTX 215.... Anybody know How to fix this????

    Guys my new GTX has the VTS on the Right handle bar and you need to press mode button first to get it to activate every time and this freaking suxs. It makes carving back and forth hard. Why the hell Do this...


  2. #2
    NateRXP's Avatar
    Join Date
    May 2013
    Location
    Richmond, TX
    Posts
    746
    +1
    180
    So your VTS up/down arrows don't work and you need to hit mode and toggle through VTS to get it to go up or down? Is that what your saying?

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Quote Originally Posted by VXRslayer21 View Post
    So your VTS up/down arrows don't work and you need to hit mode and toggle through VTS to get it to go up or down? Is that what your saying?
    Yep the GTX 215 I have only has up down arrows on the throttle side and you have to hit mode to activate VTS then the up down arrows. They state it is a cruiser and set up this way. It is difficult to use. I know there is a fix as the RXT's have it on the left with the same buttons on the right. So I assume its an upgrade.

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    bet if you swap the ECU with the same year GTR problem solved.

  5. #5
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by Water4fire View Post
    Quote Originally Posted by VXRslayer21 View Post
    So your VTS up/down arrows don't work and you need to hit mode and toggle through VTS to get it to go up or down? Is that what your saying?
    Yep the GTX 215 I have only has up down arrows on the throttle side and you have to hit mode to activate VTS then the up down arrows. They state it is a cruiser and set up this way. It is difficult to use. I know there is a fix as the RXT's have it on the left with the same buttons on the right. So I assume its an upgrade.
    Interesting. I had a 2010 GTX 215 iS and the VTS was on the left and functioned as normal.

  6. #6
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Quote Originally Posted by imp0ster View Post
    bet if you swap the ECU with the same year GTR problem solved.
    Well not really as you still need the buttons for the left side.
    Quote Originally Posted by SCHNORR12 View Post
    Quote Originally Posted by Water4fire View Post
    Quote Originally Posted by VXRslayer21 View Post
    So your VTS up/down arrows don't work and you need to hit mode and toggle through VTS to get it to go up or down? Is that what your saying?
    Yep the GTX 215 I have only has up down arrows on the throttle side and you have to hit mode to activate VTS then the up down arrows. They state it is a cruiser and set up this way. It is difficult to use. I know there is a fix as the RXT's have it on the left with the same buttons on the right. So I assume its an upgrade.
    Interesting. I had a 2010 GTX 215 iS and the VTS was on the left and functioned as normal.
    Yea, I looked into it and the GTX IS and 260's have it as normal. This is the only bastard child.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. does anybody know how to wire the magneto into the terminal board
    By H2ozone in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-10-2015, 12:19 PM
  2. Anybody know how to remove glove box lid from 2011+ GTI
    By Bensomerville in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-27-2015, 11:04 AM
  3. Anybody know how to ID the piston size from a 1300?
    By jpa1300 in forum Yamaha Open Discussion
    Replies: 9
    Last Post: 10-10-2013, 05:29 PM
  4. Seadoo Shop doesnt know how to fix my RXT...Oil Warning alarm
    By kaorder1999 in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-29-2010, 07:45 PM
  5. Anybody Know How To Remove Sponson Bolts
    By yellow4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-19-2007, 10:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •