Results 1 to 2 of 2
  1. #1

    1995 STS - no spark

    I have a 1995 STS that we just replaced the starter gear that engages the fly wheel. Picked the ski up cheap as a project. Prior owner said the starter was bad, that turned out to be the gear, it was in pieces.

    Got the ski all back together, cranks over strong but won't fire. Primed carbs with some gas, still nothing.

    I have knowledge of the SeaDoo issues around this but not the Kawasaki issues. Do these things have a computer that can go bad and it that most likely my problem? Not sure where to start testing.
    Thanks


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    No computer. Did you look at the plugs to see if they're sparking? Kawis have a lot of trouble with corrosion in the wiring harness connectors. Do you have a service manual?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 750 sl no spark
    By flash-1295 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-11-2011, 11:12 AM
  2. 1995 XP - No spark but turns over
    By KCMiller3 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-16-2010, 04:02 PM
  3. Polaris SLT 750 1995 - no spark
    By madseal7 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-30-2009, 08:51 PM
  4. slt 750 1995 no spark
    By sinclair in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-24-2008, 05:46 PM
  5. No spark-1995 spx
    By 8 is enough in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-23-2008, 06:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •