Results 1 to 5 of 5
  1. #1
    Phil33's Avatar
    Join Date
    Mar 2015
    Location
    GEORGIA
    Posts
    2

    Question On A MSX 150 Polaris

    I have a 2004 MSX 150 Polaris that I ran about 2 Years ago and after that year I had 1 that would not get up and go so I carried them down to a Polaris shop and when I got them back either would start, I think they took some parts off but I'm not sure I just know where I am today. The ski's look like brand new on the outside and I have less than 100 hours on them. My question is it will turn over but will not start. What do I need to look for and how do I need to look for it. Could it be a sensor that could keep it from cranking ? I'm not good with the handy stuff as far as fixing things. I'm in Georgia and I have friend who I talked to today that owns a Polaris Dealership who was going to talk to his Rep to see if the tool they use on Polaris Ranger would work on my Jet Ski. Thanks Phil


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,271
    +1
    157
    You will need to find a Polaris dealer with Digital Wrench (not too hard), and willing to work on watercraft and having the special watercraft diagnostics cables (hard).

    The cable part numbers are PU-47151 and PU-47102.

  3. #3
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,271
    +1
    157
    SIFB could be the cause, as described in this thread: http://www.greenhulk.net/forums/showthread.php?t=218507

    EDIT: Aftermarket ones available here: http://www.ebay.com/itm/New-Polaris-...-/171363475502

  4. +1 by:


  5. #4
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to GH Phil!

    Sorry for your troubles. The Polaris MSX 150 is a problematic ski in stock form. They were only made for one year (2004) then Polaris stopped making PWCs so they never got the bugs worked out.

    Reading your story... my first thought is... how do you take one running and one poorly running ski to the dealer and then get them both back NOT running?? What did the dealer say? Did the dealer give up on them? Did he explain what he tried to do?

    One good thing is you have 2 of them (right? both same MSX 150?). So you can swap parts to attempt to isolate the issue. When you talk about the skis, it would be very helpful to know which one your talking about. Ski-A or ski-B.

    Of all the known issues the MSX 150 can have, getting the engine to crank over isn't one of them. So both ski-A and ski-B will NOT even crank? (not talking start running, just cranking over via starter)

    Did you insert the lanyard "key" into the Stop button (left handlebar)?
    Do you have good, strong, charged batteries?
    With the battery installed... push the blue 'Mode' button (left handlebar)... does the display come to life?
    Check the engine grounds. There is a stud off the intake manifold (rear-side) that 3 (or 4?) ground ring terminals attach to. Ensure it is on and secure
    Do you see any unplugged wiring connectors? (take a picture)

    Even if you finally get it to crank... and maybe start. There are a number of things you really should inspect before even considering hitting the water... especially for the ski that was running poorly. Check back in with us and we'll try to assist.

    Any Polaris dealer that services will have Digital Wrench. But like HiPer said above... not many have the unique PWC cables needed to connect to the MSX 150... and even fewer will service them anymore. Wish you luck if you go searching for one.

    Cheers!

  6. +1 by:


  7. #5
    Phil33's Avatar
    Join Date
    Mar 2015
    Location
    GEORGIA
    Posts
    2
    I'm taking it in on Friday to have it put a Digtal Wrench. We shall see what the trouble might be. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 04-27-2011, 08:46 AM
  2. are black spark plugs normal on a msx 150!?
    By spannerspencer in forum MSX/Matrix
    Replies: 0
    Last Post: 11-29-2010, 02:58 PM
  3. Oil Tank Q on a MSX 110 Polaris
    By MarkMikenis in forum MSX/Matrix
    Replies: 0
    Last Post: 11-03-2010, 08:58 PM
  4. Pulling back driveshaft on 2004 MSX 150
    By freelancenovelist in forum MSX/Matrix
    Replies: 8
    Last Post: 11-20-2008, 07:58 PM
  5. aligning drive shaft on 2004 MSX 150
    By freelancenovelist in forum MSX/Matrix
    Replies: 3
    Last Post: 11-18-2008, 09:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •