Results 1 to 10 of 10
  1. #1

    2000 genesis problem!!! Help!!

    Hi.. I have a 2000 genesis. Battery is fully charged. No clicking but gauge has display. Won't start and intermittent spark when running. Burns thru batteries like crazy too. Could this be the stator, start/stop switch, voltage regulator? Any suggestions please!!


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,271
    +1
    157
    Fuel injected or carbureted?

  3. #3
    Quote Originally Posted by HiPeRcO View Post
    Fuel injected or carbureted?

    Carbs

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,271
    +1
    157
    Well it looks like the experts/guru's have the night off, so you're stuck with me for now (Welcome to the Hulk BTW) A good place to start is at the link below. Getting a copy of the service manual will likely be a good step as well.

    Polaris Info:> http://polarispwcknowledge.shorturl....t-things-to-do
    Last edited by K447; 03-03-2015 at 01:13 AM. Reason: Web link corrected

  5. #5
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,271
    +1
    157
    There is some electrical specific info here: https://sites.google.com/site/polari...ome/electrical

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Quote Originally Posted by JerseyDevil View Post
    Hi.. I have a 2000 genesis.

    Battery is fully charged. No clicking but gauge has display.

    Won't start
    and intermittent spark when running.

    Burns thru batteries like crazy too. Could this be the stator, start/stop switch, voltage regulator? Any suggestions please!!
    Welcome

    If it will not start, how do you get it running?

    Draining the battery is often caused by a failed LR module. You can bypass the LR-505 Start/Stop module for testing. Search for my lists with LR-505 in the post title.

  7. #7
    Thank u guys for the help... I do have a manual and will check that electrical link... I meant to say when it was running. Now I'm not getting anything at all, k447. Would a bad LR also cause intermittent spark at times? Thanks again

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Quote Originally Posted by JerseyDevil View Post
    ... Would a bad LR also cause intermittent spark at times? ...
    Yes, a failing LR module can affect engine ignition. Especially on the Virage and Genesis where the LR-505 is also the Start/Stop module.

    If the electrical feed to the CDI has been modified to conform to service bulletin PWC-00-05 then the LR module has a direct impact on CDI operation, since the LR module is controlling the electrical battery feed to the CDI.

    Doing the bypass test will remove the LR-505 from the system, allowing for further troubleshooting, if the bypass itself does not allow the engine to start and run.

  9. +1 by:


  10. #9
    Hey guys... Thanks for the reply and suggestions... I replaced the LR-505 and still nothing. No clicking, no turning over, nothing.... I was able to turn motor over by jumping across solenoid with old LR505 in there. When I jump across solenoid with new LR-505 I get nothing. Is there a hidden ground that could be off or dirty? Maybe a broken positive cable from battery to solenoid?

  11. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Quote Originally Posted by JerseyDevil View Post
    Hey guys... Thanks for the reply and suggestions... I replaced the LR-505 and still nothing. No clicking, no turning over, nothing....

    I was able to turn motor over by jumping across solenoid with old LR505 in there. When I jump across solenoid with new LR-505 I get nothing. Is there a hidden ground that could be off or dirty? Maybe a broken positive cable from battery to solenoid?
    Replacing the LR-505 is not the correct diagnostic step. Bypassing it is more useful, in terms of isolating the problem cause.

    If jumping the solenoid studs does not cause the starter motor to crank the engine then the problem cause is quite basic.

    First remove and clean both ends of both main battery cables. Pay particular attention to the engine end of the black battery cable where it is bolted to the engine case. You want zero corrosion and clean metal to metal contact. Also clean the bolt and the threaded hole in the engine.

    If still does not crank the next area is the cable to the starter motor and the starter motor itself. Sometimes the starter motor becomes internally corroded or the cable connection to the motor is bad. Last area is the bolts that hold the starter motor to the engine. These bolts also provide the electrical path between the starter and the engine case, so corrosion at the bolts can interfere.

    Note that there is a thin red wire at the solenoid. That thin red wire must be on the same solenoid stud as the heavy red cable that runs to the battery. It must not be on the stud that feeds the starter motor cable.

    If the MFI display is completely powered off and blank that is a clue that the thin red wire may be on the wrong stud. Or the engine main ground is bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Genesis 1200..... At a loss please help
    By gsxguy in forum Polaris PWC Performance
    Replies: 2
    Last Post: 09-12-2011, 09:36 AM
  2. 2000 Genesis FFI electrical problems
    By jls7707 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-07-2011, 12:17 AM
  3. 2000 genesis ficht codes 81 82 83 please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 11:19 AM
  4. 2000 genesis ficht wont rev up above idle please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-11-2010, 02:03 PM
  5. Engine troubles on 2000 Genesis--Need help
    By Budman in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-04-2009, 03:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •