Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1

    Cannot get pump off ultra 150!! Tried everything!!!

    I'm out of ideas I've tried everything I've read in here and still can't get it to budge at all!!! I even hooked the the trailer to my car and connected the pump to my dads truck and it still wouldn't budge! I'm hoping to buy this custom puller ive seen for sale


  2. #2

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    I spent at least 3 hours on it already prob more!

  3. #3
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Got a picture of what you have off so far? Any idea who put it on last and with what?

  4. #4

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    I don't think the pump has ever been off! I Have ride plate off and left steering nizzle in so Id have more leverage. I've tried using 2x4 to pry at sides of pump but it hasn't mived at all! I even tried hooking the ski to my car and the pump to the traiker hitch on my dads truck and tried to drive away and pump still would t move!!!

  5. #5
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    I assume you remove the 4 nuts that hold it in place? Been a long time since I pulled one...

  6. #6
    I use a gear puller and go stud to stud and soak. Once you get that pump off before reinstalling put a nice thick coat of grease on the 4 studs. Youll never have a stuck pump again. You did remove the two bolts that go through the ride plate?

  7. #7

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    Yeah ride plate is off all four nuts are off. I've had many ski and never had a pump this stuck!! It's insane! I went to Home Depot and bought a come along 2 ton winch and it still didn't budge!!!!! Wtf!!!!

  8. #8
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Leave force on it overnight... Also tap with hammer around the studs (dont hit them though) while you are pulling on it.

  9. #9
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    You took the two screws out of the bottom, right?

  10. #10
    it happens dude, i would use a gear puller and like r33 said you could leave pressure on it all night. stuck pump on an ultra150 who ever heard of such a thing?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help Cant get impeller off Ultra 150 Pump
    By Saltwater n Premix in forum Kawasaki PWC Performance (2-stroke)
    Replies: 23
    Last Post: 07-03-2011, 01:23 PM
  2. How to take cylinder head off Ultra 150
    By Ultra151 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 243
    Last Post: 06-24-2011, 07:54 PM
  3. Changing Pump Oil ultra 150
    By JonnyRXT in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-26-2010, 03:59 PM
  4. Possibly getting 01 ultra 150.. quick compression question...
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 07-31-2007, 07:26 PM
  5. 99 Ultra 150 Pump bearing replacement
    By gilson in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-09-2007, 01:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •