Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: flushing issue

  1. #1
    MARCO PESSOA's Avatar
    Join Date
    Jan 2015
    Location
    Rio de Janeiro - Brazil
    Posts
    36
    +1
    1

    flushing issue

    hi my 2014 fzs runs perfectly on water. no problems with overheat. but when i flush it with fresh water the overtemp light comes on. my hose has extremely good pressure and i have a lot of other friends with the same model and no problem. What can be happening??? thanks. Marco


  2. #2
    Is water coming out the front side pissers?

  3. #3
    How long are you flushing for. You really shouldn't flush for longer then a minuet, the ski shouldn't have the time to over heat.

  4. #4
    volltrex's Avatar
    Join Date
    Dec 2007
    Location
    Jersey CI
    Posts
    616
    +1
    36
    Drop the front of the trailer all the way down when on the hose.......could also clamp of the inlet hose to make sure all the water is going around the block......see if it still overheats.

  5. #5
    MARCO PESSOA's Avatar
    Join Date
    Jan 2015
    Location
    Rio de Janeiro - Brazil
    Posts
    36
    +1
    1
    all the three pissers with lots of water the jet is parallel to the ground flushing in idle speed. hose with good pressure

  6. #6
    you sure its an over heat issue then? Same light/ beeper is for low fuel, oil etc.....

  7. #7
    infamous's Avatar
    Join Date
    Oct 2010
    Location
    Long Island, NY
    Posts
    2,036
    +1
    336
    Quote Originally Posted by kwtony View Post
    How long are you flushing for. You really shouldn't flush for longer then a minute, the ski shouldn't have the time to over heat.

    This

  8. #8
    MARCO PESSOA's Avatar
    Join Date
    Jan 2015
    Location
    Rio de Janeiro - Brazil
    Posts
    36
    +1
    1
    temp warning always. oil is ok, gas ok. my friends let flushing for about three minutes and no problem. my jet has already 150hs and since 0 hs until now i used to let it flushing for about 2/3 minutes without an issue. good pressure in the pissers. this weekend this issue became.

  9. #9
    hold the button on the dash next time the alarm goes off. there are several sensors that deal with temperature in the ski, the error code might help narrow it down. Hows the thermostat?

  10. #10
    I'm with the cool kids Mowerpan's Avatar
    Join Date
    Mar 2008
    Location
    Bradenton,FL
    Posts
    172
    +1
    12
    Quote Originally Posted by kwtony View Post
    How long are you flushing for. You really shouldn't flush for longer then a minuet, the ski shouldn't have the time to over heat.
    He should be able to let it run on the hose as long as he wants without it overheating. Before changing the oil you need to run the ski to bring it to operating temperature to get as much oil as possible out of it.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 ultra 300x help asap thanks in advance flushing issues. Bilge pump?
    By Samario1984 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-05-2016, 09:56 AM
  2. 2013 Yamaha VXR Flushing Issues
    By Flamed03 in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-10-2015, 08:52 AM
  3. 2013 Yamaha VXR flushing issue
    By Flamed03 in forum Open Discussion
    Replies: 2
    Last Post: 07-06-2015, 01:53 PM
  4. 97 1100 STX flushing issue and question
    By sbklf in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 05-01-2011, 02:42 PM
  5. New guy with two issues: Depth transducer & Flush connection
    By skikodiak in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 09-18-2006, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •