Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Aquatrax Oil issue! And top speed is close to 50mph?

    Hi Guys,

    I took my aqutrax that I just purchased out. It ran fine. But the speedo only got to 50... Turbo was boosting fine and engine seems to be running fine. Was running at about 5600-5800 rpms. When I loaded it on the trailer and pulled the drain plugs oil came out of the drain plugs. It appeared to be dripping out of the air intake box. When I got home I pulled the intake off the turbo and cranked it. Turbo spool was dry and was operating fine. After it ran for a minute I checked the oil and it was filled almost to the very top of the dipstick almost at the threads of the cap. And I checked the oil in the lower side as well and it too was way about the markings on the dipstick. Would the oil be dripping out to the air box be because it is so overfilled? And since it has so much oil in it could that be slowing it down a little? I siphoned out about two water bottles full and it is still about the markings on the dipstick.


    Thanks


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    yes could be overfilled

  3. #3
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Location
    Williamsburg, VA
    Posts
    562
    +1
    2
    Overfilling can do that yes. Take note of the color of the oil though. I've seen a Honda Turbo that was leaking water slowly into the oil causing that same issue. The oil will appear a light brown color, and eventually milky. I assume you would have noticed this already if that were the case though.

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    might need to replace air filter also if it has oil on it, the Nitro method for checking oil "TM" you check when cold at rear of ski with front dipstick check it Cold should be in middle of hash I believe is method checking HOT at the front fill hole I believe to give inaccurate readings as to oil level

  5. #5
    I am looking to replace the air filter. But whoever service the ski last stripped the screws that hold the air box together... I can't get them out. I have no idea why they won't turn its plastic for Christ sake.. Tried vice grips pliers bigger screw drivers etc.. Can't get any to break free. I siphoned out about 32oz and it is still a little high but much better.

  6. #6
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    I'd do a whole oil change and only put back 3.5-4qts of oil with a new filter the screws could be cross threaded you can fab up a intake for it with a KN filter or a uni filter

  7. #7
    The oil isn't that old. The previous owner changed it a few hours ago. I sucked out the overfill and got it inline. The plugs are brand new. I ran it yesterday after I pumped out some oil, seems to be running much much better but the speedo doesn't read very well so I cant say how fast I was going. Should I be ok going forward? Also, any suggestions on how to get the air box apart? The screws that hold it together are stripped and I cant get them to turn with pliers or over sized screw drivers. I have no idea how they are so stuck.. Its plastic.. Its almost like someone put loctite on them as a bad joke...

  8. #8
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Quote Originally Posted by jhallen92 View Post
    The oil isn't that old. The previous owner changed it a few hours ago. I sucked out the overfill and got it inline. The plugs are brand new. I ran it yesterday after I pumped out some oil, seems to be running much much better but the speedo doesn't read very well so I cant say how fast I was going. Should I be ok going forward? Also, any suggestions on how to get the air box apart? The screws that hold it together are stripped and I cant get them to turn with pliers or over sized screw drivers. I have no idea how they are so stuck.. Its plastic.. Its almost like someone put loctite on them as a bad joke...
    http://www.amazon.com/IIT-90050-Scre.../dp/B001TLIJU2

  9. #9
    thanks ccw. Need to buy another drill I guess.

  10. #10
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    I would turn them out by hand. I would also soak the head side of each screw in penetrating oil 24 hours in advance to attempting to remove them.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 08-19-2012, 08:23 AM
  2. Replies: 13
    Last Post: 10-16-2010, 04:08 PM
  3. Throttle Cable, Oil issues, and Exhaust!
    By Coveted in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-04-2008, 10:56 AM
  4. RXP-X Loss of acceleration and top speed
    By laarben in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-31-2008, 03:15 PM
  5. Top speed is low
    By ventrj in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-26-2007, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •