Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Mar 2010
    Location
    Holland PA
    Posts
    239
    +1
    2

    why wont my rxp-x start?

    2008 rxp-x 81 hours... Brand new battery as of today. I bought it and charged it overnight and put it in the ski today. It's the right battery that the ski is suppose to have. Cranks over and starts for a split second then dies, and then hardly wants to crank over. Any idea what could be wrong? I will put up a video of what it is doing.
    Thanks for all the help
    Andrew



  2. #2
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,638
    +1
    159
    Sounds like the motor is been rusted or sized, maybe pump?

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Definitely more than a battery issue.

  4. #4
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,638
    +1
    159
    I hear a sweaking noise as well... Which is double confirming my motor or pump

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Could be a locked up pump, or charger issue. How long has it been sitting?

  6. +1 by:


  7. #6

    Join Date
    Mar 2010
    Location
    Holland PA
    Posts
    239
    +1
    2
    What do you guys mean by pump? Yes definitely makes a squeaking noise. Not sure how long it's been sitting. Bought t from a dealers auction.

  8. #7

    Join Date
    Mar 2010
    Location
    Holland PA
    Posts
    239
    +1
    2
    Oil pump?

  9. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by amf133 View Post
    Bought it from a dealers auction.
    Bingo! There's your problem... it was probably sunk. Sounds like you need to have someone knowledgeable with these machines take a look at it for you. Something sounds partially locked up, and there are many possibilities.

    Quote Originally Posted by amf133 View Post
    Oil pump?
    Jet pump

  10. #9
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,638
    +1
    159
    Ya, ski from an auction..... Prolly someone else's blown up beater. Hope you picked it up cheap. Sounds like it's locking up when your turning it.. Wish you lived close by, I'd look at it.

  11. #10

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    779
    +1
    39
    take the plugs out and look at them. then try to turn it over. how did u give for it ?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my rxp wont start and has excessive crankcase pressure
    By ryanj8714 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-06-2015, 09:22 PM
  2. How much water can be in my RXP before starting?
    By SuperCharged67 in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-18-2014, 02:55 PM
  3. Why wont my shock absorber stay on!!!
    By rxp12 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-17-2010, 12:03 PM
  4. why did my RXP barf out oil?...
    By DANNYA09 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-03-2006, 11:45 AM
  5. Can't Find my SPEED? MY RXP wont wake up!
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-12-2005, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •