Results 1 to 5 of 5
  1. #1

    RXT high idle after electrical fault

    Hi all

    I had an electrical issue out on the water it was a combination of a bad solenoid and a broken / burned out earth cable.
    I turned my ski off an could hear the starter motor spinning. I disconnected the battery cause I coulnt stop it and it.
    When reconnected the battery the ski was dead, wouldn't start.
    When I played with the starter solenoid it chugged slowly then stopped.
    Got towed in and found my earth cable broken at the battery connector and rusted out.
    After replacing both solenoid and cable bang it started first hit.

    My new problem is the ski now idles at 3k. I switched it off and tried it again the next day. It came down to 2k
    Now it sits between 1750 and 2k. In the past it was always spot on 1750. What could this be?
    Last edited by silverback2002; 03-19-2015 at 05:41 AM.


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Idle air valve on the TB or bad TPS

  3. +1 by:


  4. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    idle air valve issues are often momentarily resolved by removing the battery lead. DO Not manually manipulate the idle air valve to check it that will destroy it. When it does fail, t typically throws and error code. A candoo can confirm this ( and rest the tps). The iac valve is pricey, you don't really want to take a guess on it.

    get the codes out of your ecu to see what is +_really_ going on.

  5. #4
    I have no error codes. I did remove the top valve and it was a little rusty where it seats. Maybe it now needs a good run to settle it down.

  6. #5
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Quote Originally Posted by silverback2002 View Post
    I have no error codes. I did remove the top valve and it was a little rusty where it seats. Maybe it now needs a good run to settle it down.
    That's the spirit!! Pin the throttle then look through the scrap to find out what caused the issue!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High idle after stage 3 install
    By fly_kid006 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-20-2013, 12:56 PM
  2. 05 rxt wont idle after oil change "HELP"
    By jfoley in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-12-2012, 07:25 PM
  3. XLT1200 has high idle after rebuilding
    By Steveard in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-29-2011, 05:53 PM
  4. High Idle After it runs a while
    By retro in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-14-2009, 06:37 PM
  5. High Idle After Flipping Ski and Taking on Some Salt Water
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 82
    Last Post: 07-12-2009, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •