Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Dec 2014
    Location
    Denmark europe
    Posts
    31

    seadoo rxp topspeed Lost 2-3 miles

    Hello my "stock" seadoo rxp suddenly has lost 2-3 miles topspeed my wirering is new, solas impeller very locks good.
    I have a blow off kit and solas impeller and rd grate its run 8200rpm in topspeed. can anybody help me out?


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    your ski is on the rev limiter and this will limit your top speed. Possible problems are: damaged impeller, damaged wear ring, wrong impeller, too large of exit nozzle.

  3. +1 by:


  4. #3
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,638
    +1
    159
    8200rpm is more then I'm seeing on mine and I'm running 69mph all stoxk

  5. #4
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,638
    +1
    159
    I hit around 8100, 8050

  6. #5

    Join Date
    Dec 2014
    Location
    Denmark europe
    Posts
    31
    Click image for larger version. 

Name:	10313052_10153169679903970_9006094516393077271_n.jpg 
Views:	51 
Size:	34.0 KB 
ID:	353835
    Here is my impeller its locks nice and wearing is new stainless steel.

  7. #6
    DPG98GSXL's Avatar
    Join Date
    Feb 2007
    Location
    East Tennessee
    Posts
    559
    +1
    23
    Quote Originally Posted by oste-frans View Post
    Hello my "stock" seadoo rxp suddenly has lost 2-3 miles topspeed my wirering is new, solas impeller very locks good.
    I have a blow off kit and solas impeller and rd grate its run 8200rpm in topspeed. can anybody help me out?
    Hell, I wish I was getting numbers like that...

  8. #7

    Join Date
    Dec 2014
    Location
    Denmark europe
    Posts
    31
    its only run 106km/t (66miles) normaly 113km/t(70) so all the numbers is not good

  9. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Did you just install the wearing and impeller?

  10. #9
    Lightning1's Avatar
    Join Date
    Mar 2013
    Location
    Illinois
    Posts
    367
    +1
    29
    Is the blow off leaking? I thought that is why most people don't run them

  11. +1 by:


  12. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    ..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Seadoo RXP X 260as lost all dash and ignition
    By Addog01 in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-20-2014, 12:48 PM
  2. Seadoo RXP vs Yamaha GP1300R
    By trevo in forum Open Discussion
    Replies: 19
    Last Post: 01-22-2013, 05:52 AM
  3. seadoo rxp skat-trak magnum pump.....
    By nacho libre in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-07-2011, 08:37 PM
  4. Kawasaki stx 15f 2009 topspeed compared to seadoo rxp 2005
    By centrino in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-07-2011, 09:56 AM
  5. Seadoo RXP 0 ours wont start!
    By mickgrom in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 10-23-2006, 02:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •