Results 1 to 6 of 6
  1. #1

    2007 215 wake, lost power

    I have a new to me 2007 SC Wake 215hp. &nbsp;First time on the water today. &nbsp;I had Jerry rebuild the SC before I put it on the water. &nbsp;Idled and ran great and then I took off, started losing power so I turned around and put it up. &nbsp;Acts like its running out of fuel. &nbsp;It will sometimes take off again but it's not running right. &nbsp;Any suggestions? &nbsp;It bogs down from idle and sounds rough. &nbsp;I checked the plugs and they look ok, I'll replace those anyway. &nbsp;Something is off as it took off great then fell down.<br><br>Thanks in advance!


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    More than likely it's the spark plugs... even though they look fine.
    They tend to foul out when the ski sits for a long period of time.

  3. +1 by:


  4. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    my bet also

    ..don't go by looks alone on a 4-tec. plug glazing is trickery that cost me a lot of time early on when I started my business. They _look_ good...but they are not. changing them is always the first step in resolving "it runs like crap" complaint.

  5. #4
    OK thanks, I'll give it a shot. Hopefully it's that easy!

  6. #5
    Quote Originally Posted by Rustyed View Post
    OK thanks, I'll give it a shot. Hopefully it's that easy!
    spark plugs fixed it, thanks all!

  7. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    thanks for reporting back..that will result in somebody else with the same issue hopefully finding your "changed it /fixed it" thread and reap the benefit.

    plugs glaze easily it seems on a 4-tec. keeping a spare set of plugs and a wrench on board can be a day saver

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXP 215 loss of power
    By Rob1124 in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 07-26-2016, 02:29 PM
  2. Anybody Recognize this Seal? 2007 Seadoo 215 Wake
    By rferrel1 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-20-2014, 10:09 PM
  3. 2007 215 hp wake edition what to look for?
    By baba850r in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-23-2014, 09:29 PM
  4. 2007 SD 215 Wake supercharger question
    By My_IS-F in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-12-2014, 06:51 AM
  5. 05 rxp lost power
    By 1969camaro-rs in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-10-2005, 08:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •