Results 1 to 4 of 4
  1. #1
    Suthrn's Avatar
    Join Date
    Jul 2006
    Location
    Delaware
    Posts
    318

    A little water in hull?

    I recently replaced my impeller, got the pump wedge, riva rear air intake, and SC washers. I went for the first ride yesterday and was out about a hour and a half. There were no waves or ruff riding going on just speed runs. The ski had a little water in the hull. I am guessing about 12 ounces or so. Didn't know if I should be looking for something wrong or if this is somewhat normal?


  2. #2
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Here's my take. I learned a long time ago that if it rides on water, somehow it will find its way in. It may be as simple as the hull flexing a bit and it sneaks in where the OPAS is blocked. As long as it is not like gallons and gallons, you will be OK.

  3. #3
    Suthrn's Avatar
    Join Date
    Jul 2006
    Location
    Delaware
    Posts
    318
    Quote Originally Posted by Red Devil View Post
    Here's my take. I learned a long time ago that if it rides on water, somehow it will find its way in. It may be as simple as the hull flexing a bit and it sneaks in where the OPAS is blocked. As long as it is not like gallons and gallons, you will be OK.
    It's odd you mention the OPAS because of all the stuff I did that is the one area that doesn't seem right. It didn't go back together too smooth and I had to put a little pressure on it to get the bolt holes to line up. I can also feel that it has made the steering tight in a couple of spots. Maybe I am reaching for straws but maybe the stress on the OPAS that has been applied is causing a small water leak where you say. I guess I'll just have to continue to monitor and see.

  4. #4
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    The OPas system will be a major water leak for people as the boots dry rot. I`ve seen skis with zero hours leak at the boots. A lil is not a prob.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. is this normal? a little water in the hull.
    By MartinsRxp in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-05-2014, 09:39 PM
  2. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM
  3. Water in Hull
    By UFO-RXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-21-2005, 06:40 PM
  4. Alot of water in hull
    By Drake in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-26-2005, 07:42 PM
  5. RXP Water in Hull
    By jpwt62 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •