Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2005 sea rxp check engine light on

    My ski check engine light comes on right after take off got know power and runs like crap any help out there. It might run 35 mph.


  2. #2
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    Welcome to Greenhulk. With safety lanyard on its post, press the set button 5 times, it should display a P-code. Then do a search for that code number. Should be a lot of info on this site

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    It's going into limp mode. Check oil level, and all connections to sensors on the engine. The code will tell u which sensor is causing it.

  4. #4
    It is only showing the 1517 code which something to do the compass. Will this cause it to run this way

  5. #5
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    That code will not cause it to go into limp mode. Its usually something oil sensor or temp sensor related that will cause limp mode. Was anything done to the ski just prior to the issue you're having?

  6. #6
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    245
    +1
    35
    Low oil pressure will result in a long beep and go into limp mode. Check your oil.

  7. #7
    No just put new batter in it and to it out this weekend and it ran how I describe it.

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by robbie66 View Post
    It is only showing the 1517 code which something to do the compass. Will this cause it to run this way
    If you are getting this code, you probably left the battery dead for too long and the ECU lost its programming. U most likely won't have a VTS trim indicator on the dash as well. This will require a Dealership visit to get fixed.
    As for the limp mode / beep, red light flash, u probably have mode codes than just Compass. U can scroll thru all the codes by pressing MODE a few times after pressing the SET button 5 times to get the codes. Scroll thru till it says END and has a short beep. write down all the codes shown.

  9. #9
    Thanks for all the help. I'm going to see what I can do

  10. #10
    Alright i have realized my knock sensor is bad , can I just change the sensor and ride or do I need to take to dealer

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 sea rxp check engine light on
    By robbie66 in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-22-2015, 09:15 PM
  2. 2005 RXP - Check Engine Light
    By DonVito in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-16-2014, 08:04 PM
  3. Ski check engine light on break in period question
    By djohnson44 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-14-2012, 12:11 AM
  4. check engine light on a gp 1300 2007
    By rolo2230 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-30-2009, 02:05 PM
  5. check engine light on s200
    By r1_123 in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 08-12-2009, 09:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •