Page 1 of 5 123 ... LastLast
Results 1 to 10 of 50
  1. #1
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,899

    knock sensor going bad?

    Anyone have a knock sensor go bad? What were your symptoms?

    My symptoms are reduced RPM's/lacking power and it stumbles at idle.


  2. #2
    How did you know the knock sensor took a dump?...PR...

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,899
    I don't know it took a dump. I just suspect it is on its way out.

  4. #4
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    It isn't common for a knock sensor to go bad. I'd first check wiring, other sources of noise like Real knock, bearings, piston slap, ect.

  5. #5
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Jerry, I have one for you if you want it. That was one of the 6 million things I changed on my ski when I was gremlin hunting.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,899
    Frank, send it to me if you don't mind. I need to trouble shoot this damn thing. It's either the damn sc clutch, or knock sensor.

  7. #7
    Can you hear an audible knock? I have to assume you looked at everything else, ie: plugs etc. ...PR...

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,899
    No, no audiable knock. Engine runs great just lacking in power and down to 8100 RPM's.

    Today i tried:
    Changing the plugs
    Changing the injectors
    Reinstalling the fuel controller (to bypass the RR ECU fuel controling capabilities)
    Pulled my pump and prop and made sure no blades were kicked out.
    Installed a different pump in case the other one had bearing problems.
    Installed largest venturi ring to help get R's up.
    Compression tested perfect!

    Nothing helped!

    It's either the new SC clutch is slipping (i will know for sure once my snap on torque wrench shows up) or its the damn knock sensor.

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,899
    This all happened the day i built my new supercharger. I went out for some test runs and i was pulling 8400 RPM's at 77+ MPH and 20 minutes later my R's were down to 8100-8150.

    Came home and shimmed the clutch. Unfortunately i cannot accurately measure the slipping moment until my new torque wrench arrives

    The more I think about it the more i tend to think the sc clutch is slipping

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    you've heard the magic number before jerry... if the knock sensor was the culprit, i've consistently seen 7700-7800 RPMS be the indicating rpm of that issue... that rpm range was notorious at the beginning of the season, and in several circumstances i saw the knock sensor wiring being the issue. on both stock and RR equipped skis.

    what was up with the SC assembly that u originally had in there that u sold? wasn't it working perfectly, and u sold it and rebuilt urself a 2006 clutch? see what happens when u tinker with it too much, haha.

    hope u get the issue worked out soon... i know you must be dying inside to play with that new pump and the riva intercooler.... i know i'm excited for you thinking that maybe something in the mix will give you 79-80

    your previous clutch was a RR HD clutch, and this was your first time running a 2006 clutch, right?

    when's the torque wrench supposed to be delivered?

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how do you know when knock sensor is bad
    By BGslugger10 in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-01-2009, 02:55 PM
  2. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  3. Knock Sensor update piggy back harness???
    By Pale Rider in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-16-2006, 08:36 PM
  4. Knock Sensor
    By meeper in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-08-2005, 10:43 AM
  5. Latch & Knock Sensor Recall
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-01-2005, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •