Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 48
  1. #1

    2001 Virage only runs on water for about 200 yards and shuts off

    I have a 2001 Virage that I am new to working on I just got the ski and was told when is hooked up to the hose it will run all day when on the water it will only run about 200 yards and shut off

    hoping someone can help me with this before I have to get it out and find out what happens any thing will help
    Last edited by K447; 03-25-2015 at 09:12 PM. Reason: Thread title typo


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    welcome aboard the GH.

    Check the signature links for info on all things Polaris.

    carbed or injected?

  3. #3
    Quote Originally Posted by nmpeter View Post
    welcome aboard the GH.

    Check the signature links for info on all things Polaris.

    carbed or injected?
    It is carbed

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by bbritton29 View Post
    I have a 2001 virage that I am new to working on I just got the ski and was told when is hooked up to the hose it will run all day when on the water it will only run about 200 yards and shut off hopping someone can help me with this before I have to get it out and find out what happens any thing will help
    Service history?

    Has it been repaired recently?

    When did it last run properly?

    After it shuts off will it restart? Right away?

  5. #5
    Not sure on what was done I just got the ski hopping someone can give me a few things to look over I know there was a new battery put in it and I was told it will restart about 5 minutes later

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by bbritton29 View Post
    Not sure on what was done I just got the ski hopping someone can give me a few things to look over I know there was a new battery put in it and I was told it will restart about 5 minutes later
    This is now your machine?

    Since you just got it I would advise that you go through it and do all the inspections and recommended maintenance. Somewhere along the way you will probably find things that are not as they should be.

    Check cylinder compression. All spark plugs out, throttle held wide open. You want less than 5% variation from highest to lowest cylinder. Check each cylinder more than once, look for consistency. Do not add oil to the cylinders before testing. Strong battery is required.

    Disconnect battery, open electrical box. Look for signs of water or moisture inside. It should be 100% dry inside. On that model year there may be two electrical boxes.

    Electric reverse, if your model has it, should work while the Bilge button is held down. Bilge pump should also run.

    See my signature links for other recommended service items, including carb rebuild, replace fuel selector valve, new fuel hoses, rebuild jet pump bearings and seals, through-hull bearing with new seals. And so on.

  7. #7
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Try running it on the trailer, in the water, with the seat off. See if you can get it to "die".

    I always start with the basics. You need, Spark, Fuel, and compression to run. Determine what is missing from this equation, and diagnose from there.

    I run machines on the trailer ( or will ride sometimes) with the seat off, and spark testers installed, looking to see if you loose spark when it dies. ( I am betting this is your issue).

    Will it continue running with the choke pulled? ( fuel issue if it does).

    Check out and report back. K447 has some very good diagnostics links, but it is hard to do before knowing what is really wrong.

  8. +1 by:


  9. #8
    Thank you for the info how hard is it to rebuild the jet pump

  10. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by bbritton29 View Post
    ... how hard is it to rebuild the jet pump?
    See the Jet Pump section in my signature links.

  11. #10
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Quote Originally Posted by bbritton29 View Post
    Thank you for the info how hard is it to rebuild the jet pump
    Jet pump is really pretty easy / straight forward. I have rebuild kits in stock here.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Virage-i only runs on WOT
    By wallflood in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-12-2015, 08:37 PM
  2. Replies: 10
    Last Post: 07-06-2015, 12:38 PM
  3. Question about running in water for first time
    By shaun23a11en in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 05-19-2012, 04:49 PM
  4. 2001 VIRAGE TXI- running lean
    By SMOKEWAGON in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-05-2007, 08:18 AM
  5. GP800 only running on one cylnder... why?
    By rnq124 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-23-2006, 10:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •