Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2007
    South Jersey

    steering 2002 genesis i

    Hi to all. New to this forum. Can someone tell me how to grease my steering column? I get a lot of squeeking while tuning handle bars. I have tried squirting WD40 where I can to no avail. Thanks!

  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    Welcome to the fourm! Here is a picture from the manual and it doesn't look as if there are any greese fittings on the steering column. All it says in the manual is to grease the bushings. You might check the cable to make sure that is not the source if your squeek.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Steering.JPG 
Views:	55 
Size:	85.6 KB 
ID:	21743  

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Hi waterslicker, WELCOME to the Green Hulk Forums!!
    As suggested, remove the cable connector and lubricate.
    Turn your bars with the cable disconnected, if it still squeaks you can try removing the bar pad and see if it's the source of your noise.
    If not, dis-assemble the steering assembly and lube her up.

  4. #4

    Join Date
    Apr 2007
    South Jersey

    Thumbs up

    thanks for your help.will give it a try.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Parting out my 2002 Genesis 1200 DI
    By vxrpete8 in forum Polaris Classifieds
    Replies: 84
    Last Post: 07-17-2015, 11:09 PM
  2. 2002 Genesis i won't start when cold or 'cool'
    By K447 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 12-10-2009, 03:12 PM
  3. 2002 Genesis i - No spark
    By skiversinc in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 12-05-2009, 01:40 PM
  4. 2002 genesis txi, has to warm up for 5 min
    By kc44408 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-04-2009, 08:42 PM
  5. 2002 genesis i starting problem
    By tt1 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-05-2009, 12:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts