Results 1 to 8 of 8
  1. #1

    Factory Depth Finder Installation 2008 RXT 255 Detailed Instructions with photos

    Just finished installing the factory depth finder into my 2008 RXT 255. This is kit # 295 100 324. Ensure you call the parts place and give them your VIN number to ensure you get the right kit, some dealers say these are not returnable.
    You will find that the attached gives you very detailed installation instructions, something I was looking for prior to starting but no one had any. I have not yet had this activated by BUDS or tried it. I will report back when that is done.
    I spread my job out over 3 days, taking my time, letting adhesives dry, etc. Anyone can do this, patience is a must!
    Please note that NO "special" tools are needed. You probably already have everything in your tool box.
    Please let me know if you have any questions.

    Jim
    Attached Files Attached Files


  2. #2
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    great mod,love mine.

  3. #3
    Great write up. I don't need it, but great to keep topping the forum knowledge bank up. Well done.

  4. #4
    First time out:
    After taking to local dealer to have module activated. Into the water and off we went. Depth finder on dash display showed _ _, depth finder was not picking up. I figured I would fault isolate it later. Up the river we went taking it easy for first time out of the season. Went about a mile and my son wanted to drive it back to the launching point. He took over and got her up to around 45 or so and was increasing speed when the doo started to sound funny, much louder rumble coming from under the seat. He steered her towards the shore where she died. Tried re-cranking few times to no avail. Finally son looked at dash display and said "Hey, the depth finder is working", and working perfectly it was. After taking the seats off I could tell we had taken on water, never before had this occurred. After looking intensely I observed that the exhaust chamber had pulled out from the hose, which apparently floods it with water. Dummy me I had forgotten to tighten that "radiator" type clamp sufficiently. The water had gotten into the hull and allowed sufficient transfer of the ducer signal so that it worked. After working the chamber for about 5 minutes, I was able to get it back into place. Luckily my son had his multi-tool on his key-chain, which contained a flat-blade. I was able to use the flat-blade to tighten the clamp and after letting her sit for awhile longer she fired right up. About a week later (today), started checking her out. Discovered that the depth finder was loose, had not thoroughly clipped into the base initially or came loose somehow. I am hoping that is all that was preventing it from reading in the first place. Got that clipped in correctly, checked all other hose clamps, and I am ready to take her back out. I will provide an update soon.
    Jim

  5. #5
    Premix's Avatar
    Join Date
    Mar 2014
    Location
    Pt Pleasant NJ
    Posts
    178
    +1
    5
    Quote Originally Posted by CotacaCreekRXTX View Post
    First time out:
    Discovered that the depth finder was loose, had not thoroughly clipped into the base initially or came loose somehow. I am hoping that is all that was preventing it from reading in the first place. Got that clipped in correctly, checked all other hose clamps, and I am ready to take her back out. I will provide an update soon.
    How did everything turn out? At what speed does the depth sounder stop working?

  6. #6
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    The OEM depth finder on my 2013 GTX stops working about 30-35mph.

  7. #7

    Final Results from Installation

    Everyone,
    Sorry for the very late reply.
    In my last post I spoke about the incident where we took on water, tightened up the exhaust clamp and took her to shore. We have taken her out several times since then and the depth finder has operated flawlessly at all speeds. We have had absolutely no problems at all.
    Me Very Happy!
    Jim

  8. #8
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Both mine work going 78 on dash no problem on my 30"'s

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Depth Finder install 07 RXT
    By Ken62465 in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-24-2014, 06:36 PM
  2. Depth Finder Install RXT-Power from "MPEM????"
    By asaberan in forum 4-Tec Performance
    Replies: 19
    Last Post: 10-06-2009, 10:42 AM
  3. Depth finder install on 2008 RXT-X
    By iflyems in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2008, 03:39 PM
  4. RTX 2007 Depth Finder Install?
    By Muddy River in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-09-2007, 07:15 PM
  5. My Hawkeye Depth Finder installation
    By lafjax in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-02-2006, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •