Results 1 to 10 of 10
  1. #1

    Kawasaki 12F Drains Battery

    Several issues:

    I must clean cables every time I connect battery, or it won't start.
    Then, once on the water, after 15 minutes of riding or so, then a break, next time it won't start.
    Twice while riding, the jet ski just completely cuts off.

    Is this a cable issue, or something else?


  2. #2
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    my guess is that it is not a cable issue.

    Sean

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    either corroded/broken battery cables, or dirty contacts on the solenoid, or battery needs replacing. check the charge rate and get the battery load tested.

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,158
    +1
    600
    or maybe ....just maybe the battery is stuffed !!!!!!!!!!

    even new batteries fail...........swap it out 1st ly

    Waz

  5. #5

    Kawasaki 12F Drains Battery

    Quote Originally Posted by sirbreaksalot View Post
    or maybe ....just maybe the battery is stuffed !!!!!!!!!!

    even new batteries fail...........swap it out 1st ly

    Waz
    I have 3 new batteries, and they work perfectly on other jet ski.

    May be cable, as you guys state.

    Is replacing ground cable doable? Seems like it goes under engine?

  6. #6
    RLACEMAN's Avatar
    Join Date
    Aug 2011
    Location
    Random Lake WI
    Posts
    884
    +1
    54
    I'm guessing that when you remove the battery cables then connect them again something is resetting, does it have the same effect if you don't clean the cables? I don't know what could cause this, could be a faulty relay or solenoid somewhere, does the digital dash display work normally?

  7. #7
    Quote Originally Posted by RLACEMAN View Post
    I'm guessing that when you remove the battery cables then connect them again something is resetting, does it have the same effect if you don't clean the cables? I don't know what could cause this, could be a faulty relay or solenoid somewhere, does the digital dash display work normally?
    Sometimes, the digital display does not come on. But, I move the ground cable around, and all of a sudden, display comes on. But, does not mean jet ski will start. I can still have the one click sound. Then after routine of cleaning battery cables leads, it starts. When it starts, it is a strong start. And no rough idle.
    Could it be I am just moving ground cable in "right" way, and then it starts?

  8. #8

    Join Date
    Aug 2011
    Location
    Australia Melbourne
    Posts
    839
    +1
    137
    A simple battery load check

    Check battery for amount of voltage drop while cracking

  9. #9
    clean all connections first. Remove the cables and scrape with a razor blade until you see shiny metal. Do the same with the contact points on the ski and the battery terminals. Don't use a wire brush because all you're doing is polishing the dirt. Check the water levels in the bat and have it load tested by a mechanic. use a mirro to see the ground connection under the motor. Somewhere there is a corroded cable or bad connection.

  10. #10

    Kawasaki 12F Drains Battery

    Quote Originally Posted by ddowers View Post
    clean all connections first. Remove the cables and scrape with a razor blade until you see shiny metal. Do the same with the contact points on the ski and the battery terminals. Don't use a wire brush because all you're doing is polishing the dirt. Check the water levels in the bat and have it load tested by a mechanic. use a mirro to see the ground connection under the motor. Somewhere there is a corroded cable or bad connection.

    Will try this. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 06-17-2016, 11:48 AM
  2. STX 12F 2003 Battery warning and battery draining and display problem
    By Leep in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-17-2016, 11:48 AM
  3. Kawasaki 12F Drainig Battery
    By kauferlie in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 03-19-2014, 01:18 PM
  4. Kawasaki 750SS Drain Plug-Where is it???
    By jarcynvicnchris93 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 06-08-2008, 09:13 PM
  5. drained battery
    By buddydoo in forum 4-Tec Performance
    Replies: 24
    Last Post: 10-15-2007, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •