Page 1 of 37 1 2 3 11 ... LastLast
Results 1 to 10 of 369
  1. #1
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13

    pulled Supercharger for rebuild, look what i found 127 hrs ops !!!


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG6082.jpg 
Views:	1436 
Size:	99.0 KB 
ID:	355360   Click image for larger version. 

Name:	IMAG6083.jpg 
Views:	1409 
Size:	87.8 KB 
ID:	355361  
    Last edited by kensmith; 11-28-2015 at 12:54 AM.


  2. #2
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,088
    +1
    108
    Stock charger ?

    Any noticeable play in the bearings ?

  3. #3
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    Quote Originally Posted by canuck View Post
    Stock charger ?

    Any noticeable play in the bearings ?
    I can barely (& I mean BARELY) feel some back and forth but it dont feel like enough to hit sides but I guess it was !! Sucks after $300 plus for rebuild kit now another surprise, Im wondering if I should go with an aftermarket OEM performance replacement with no mods needed like Riva or R&D .. ..
    it Just barely touched even with my finger running across I can barey feel a dip, I may have to replace housing half ? or maybe I can smooth it out ? it was.

  4. #4
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    I know I didn't have to pull waterbox, but there ALOT more room this way plus I have an exhaust spacer on the way.






    Special Topas grease for supercharger.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG6072.jpg 
Views:	891 
Size:	107.1 KB 
ID:	355439   Click image for larger version. 

Name:	IMAG6075.jpg 
Views:	851 
Size:	43.6 KB 
ID:	355440   Click image for larger version. 

Name:	IMAG6078.jpg 
Views:	851 
Size:	114.1 KB 
ID:	355441   Click image for larger version. 

Name:	IMAG6077.jpg 
Views:	832 
Size:	86.9 KB 
ID:	355443   Click image for larger version. 

Name:	IMAG6081.jpg 
Views:	844 
Size:	46.2 KB 
ID:	355444  
    Last edited by kensmith; 11-28-2015 at 12:54 AM.

  5. #5
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    It's the supercharger monster ... Hungry again ...

  6. +1 by:


  7. #6
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    Quote Originally Posted by SLASHER View Post
    It's the supercharger monster ... Hungry again ...
    LOL

  8. #7
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    I just had the same problem with a c kit ... Bearing , clutches fine .. It may be water injestion but the stock 215 wheel are built like a tank . Can't see it flexing.

    Yep S/C monster ...��

  9. #8
    Banned User
    Join Date
    Sep 2014
    Posts
    1,150
    +1
    129
    The kraken

  10. #9
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Leakdown test your cylinders, clean your manifold and your IC.

  11. #10
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    Quote Originally Posted by SLASHER View Post
    I just had the same problem with a c kit ... Bearing , clutches fine .. It may be water injestion but the stock 215 wheel are built like a tank . Can't see it flexing.

    Yep S/C monster ...��
    Funny thing is I spin it on the bench and I hear no contact so maybe only under high RPM or heat ?

Page 1 of 37 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Look What I found
    By rlharrison60 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 07-11-2008, 06:46 AM
  2. Look what I found today
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-08-2008, 01:05 PM
  3. Look what I found when pulling the head??!!
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 27
    Last Post: 06-23-2008, 10:21 PM
  4. Well SCer maintenance and look what I found!
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-24-2008, 12:36 AM
  5. Look what I found...
    By Rodneyae in forum Polaris Open Discussion
    Replies: 11
    Last Post: 12-17-2007, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •