Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Av8tordude's Avatar
    Join Date
    Dec 2014
    Location
    Doha, Qatar
    Posts
    73
    +1
    3

    Extreme Oil Consuption

    Ref: 2014 X-T (10 hrs)

    I recently did an oil change with the dipstick indicating 3/4 full after I was finished. Yesterday I went riding for approximately 1 hr to enjoy the Sport Mode function for the first time. After pulling my ski out of the water, I checked the bilge for any leaks and didn't notice anything usual (i.e. lose hose, fittings, etc). The bilge had only insignificant puddles remaining (not unusual to my knowledge). After completing my post care cleaning, I checked the oil level and the dipstick was indicating near the bottom tip of the dipstick. So I have a few questions...

    Does these muscle craft consume so much oil on 1 ride?
    How often should I be replenishing oil?
    If I have an oil leak, where could it be leaking from?

    I checked the PTO Seal, as suggested in a few threads I searched but I didn't see anything unusual.

    Thanks!


  2. #2
    drugnas's Avatar
    Join Date
    Dec 2014
    Location
    GREECE
    Posts
    26
    +1
    1
    run engine for 10sec at 4000rpm and shutt off at this rpm.This will move the oil from pto housing to oil tank

  3. #3
    Av8tordude's Avatar
    Join Date
    Dec 2014
    Location
    Doha, Qatar
    Posts
    73
    +1
    3
    Thank you for responding...

    Is this the proper way of checking oil levels after each run? Just out of observation, my understanding from reading many threads on oil change procedures, to check the oil levels, one would only need to warm the engine and to make sure the ski is level to get a proper reading.

  4. #4

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    838
    +1
    127
    Did you note how much oil you removed? How much oil did you install? I doubt the engine consumed that amount of oil. There are two reservoirs for oil and to get an accurate reading the level should be checked with the engine warm and within a couple minutes of shutting the engine down. It took me many attempts to learn how to get an accurate oil level reading on this engine.

  5. #5
    Av8tordude's Avatar
    Join Date
    Dec 2014
    Location
    Doha, Qatar
    Posts
    73
    +1
    3
    I removed 3.75 qts. I put in 3.25 qts.

    So do I always shut the engine down at approximately 4K RPMS?

  6. #6
    ProZadoX's Avatar
    Join Date
    Jan 2008
    Location
    Ottawa, Canada
    Posts
    351
    +1
    55
    This is simply a case of improper oil level check procedure.

  7. #7
    Av8tordude's Avatar
    Join Date
    Dec 2014
    Location
    Doha, Qatar
    Posts
    73
    +1
    3
    Ok...forgive my ignorance as I'm a F.N.G. to the PWC arena. What's the proper way of checking the oil level?

  8. #8

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    838
    +1
    127
    Quote Originally Posted by Av8tordude View Post
    I removed 3.75 qts. I put in 3.25 qts.

    So do I always shut the engine down at approximately 4K RPMS?
    This is done during the oil removal process to move as much oil as possible to the oil tank where it can be siphoned out. Did you also change the oil filter? Did the engine run fine?

  9. #9
    Av8tordude's Avatar
    Join Date
    Dec 2014
    Location
    Doha, Qatar
    Posts
    73
    +1
    3
    To have an understanding of my mechanical abilities, I do most of the mechanical repairs of my car that don't involve removing the engine (I know, not the same), so changing the oil was not a difficult task once I educated myself on the proper procedures.

    I changed the oil filter and the engine ran fine (no anomalies). Only thing I happened to notice, 1-steady beep after the engine has started (last about 0.5 - 1 sec). The OTAS and IBR light stays on about 1/2 a sec then they extinguish (my guess, the computer is running a system check). There are no fault codes displayed. (Yes, I know and did check to see if there were any.)

    Lastly, still haven't got an answer about how to proper check the oil levels on my ski. (Not being sarcastic, just trying to get a thorough understanding of properly maintaining a ski).

    Thanks.

  10. #10
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How-To: Oil Change
    By Sunfunzoom in forum Sea Doo How To & FAQs
    Replies: 280
    Last Post: 06-28-2017, 08:34 PM
  2. 2002 Genesis I FICHT oil pump extremely hot
    By 440/650 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-28-2011, 08:16 AM
  3. 10 Hrs. on RXP oil change??
    By RXPNJ in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-09-2006, 08:55 AM
  4. Extreme tubing!!
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2005, 12:23 AM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •