Results 1 to 3 of 3
  1. #1
    jajardas's Avatar
    Join Date
    May 2014
    Racine, WI

    Added 2 more units to the Polaris Fleet...

    Went and picked up the 2001 Virage and 1999 SLTH from the transporter(AKA My Dad) and I would have to say these are some clean skis. Trailer is near mint also. The PO only could get one started when my Dad arrived. I did not know what one so I checked them over. Installed two new batteries, compression on each was 120 on all cylinders with my gauge. So that looks good. Put on the spark tests and both fired right up. Now just need to get them down to the launch to test them on the trailer before a maiden voyage.

    ***All my Wetjet and FUJI skis along with the extra parts will be up for sale*** might even part with a double trailer or two.
    The 2 that run and are not part units are in my avatar.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	virageslth.jpg 
Views:	36 
Size:	114.5 KB 
ID:	355786   Click image for larger version. 

Name:	virageslth2.jpg 
Views:	39 
Size:	96.7 KB 
ID:	355787  

  2. #2

    Join Date
    Apr 2015

  3. #3
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    You need something with some pipes in it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I have a Polaris Problem adding another one to the fleet.
    By jajardas in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-13-2016, 09:07 PM
  2. Replies: 5
    Last Post: 07-30-2014, 05:30 PM
  3. Replies: 4
    Last Post: 07-27-2014, 09:49 PM
  4. PWCtoday no post in over 2 days in the Polaris section!
    By ZMANN in forum Polaris Open Discussion
    Replies: 13
    Last Post: 01-11-2007, 02:27 PM
  5. Replies: 42
    Last Post: 11-12-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts