Results 1 to 5 of 5
  1. #1
    waz480's Avatar
    Join Date
    Oct 2012
    Location
    Meopham, United Kingdom
    Posts
    91
    +1
    5

    2012 RXP260 Melted out fuse box and Harness

    Click image for larger version. 

Name:	20150412_122739.jpg 
Views:	567 
Size:	103.7 KB 
ID:	355791

    Hi There,
    I was riding my RXP when i cut out all the display disappeared , I tried removing the key and replacing it still no display or start, I got towed back to shore put the ski on the trailer and checked the fuses and found to my shock the 30amp charge and 30amp battery fuses and part of the fuse board melted out the fuses had not blown , I knew the harness was trashed so i cut the wires off the back of the fuse board and connect in line 30amp link wires , After doing so the battery was too flat to start the ski so i charged the battery while it was charging i had a good look over all the connections and earths and found the 3 yellow wires melted coming from the stator , Once the battery was charged the display came on and the ski started a checked the voltage when running and it was 13,6 volts so went for a short test ride , I checked the fuses of found the 2 i had bypassed had all most melted out again , I then pulled the whole harness out cut back the outer cover and checked every part of it and a part from what i a mentioned above and what damage is in the picture could not see anything wrong ,I managed to buy a used harness from a 2014 RXP260 i checked all the plugs and all seamed the same until i looked at the fuse layout and could see the wiring was different , I checked the part number between 2012 and 2014 RXP'S and the part numbers are different as are the ECU and engine harness part numbers are , I can not return the 2014 harness or afford a new harness but am frighten to connect the battery and test it in case it causes more damage , I would like to know if anyone can shed any light on the melted out fuse and wiring please and anyone know if the 2014 main harness will work with my 2012 ski please ,
    Thanks for reading
    Cheers,
    Waz


  2. #2
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Sounds like the voltage regulator to me.

    part REF No. 188 http://partsfinder.onlinemicrofiche....ATTERY-HARNESS

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    the dess is rf on the 14

  4. #4
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    Quote Originally Posted by skidoochris View Post
    the dess is rf on the 14
    No it is not. Just the spark is..

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    oops!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2-Stroke Plz Help! 98 GP800 Buzzing from fuse box and wont turn over
    By CrownVicNick in forum Yamaha Projects & Build Threads
    Replies: 1
    Last Post: 04-27-2013, 06:10 PM
  2. Relocating fuse box and ECU
    By racerx585 in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 02-25-2012, 02:13 PM
  3. Relocating Fuse box and ECU
    By racerx585 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 02-21-2012, 12:09 PM
  4. WTB Question and i need 2 fuse box covers 4tec gtx 2004
    By marc777 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-29-2010, 12:32 AM
  5. Clicking noise at fuse box and ski wonts start at times.
    By excess in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-08-2007, 09:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •