Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    questions about scom on svho. Feels slow?

    I just took the ski out today with the ribbon delete and scom i completed this past weekend, the ski chugs alot more gas and the take off doesn't seem as good as it was stock. I only have ribbon delete and scom. Does anyone else know if this is normal or not?


  2. #2
    No aftermarket intake?? Think you need to add one now that you removed that huge restricter in your manifold

  3. #3

    Join Date
    Apr 2006
    Location
    FRESNO, CA.
    Posts
    150
    +1
    4

    questions about scom on svho

    Did you do any testing with your application? What results did you get? I also just installed a Riva scom on my '14 svho FZS with 2hrs. The ski pulls hard up to 7700-7800rpm, and just when it feels like its going into hyperdrive, it falls flat back, down to 7500 and stays there. I can quickly release the throttle and immediately pin the throttle again, and it will zip up to 7700-7800 and fall back to 7500 again. Obviously, its hitting the limiter. But isn't the scom suppose to bypass the limiter?! Or is the ECU locked in for break-in??
    By the way, I was able to GPS 70.7. The ski feels like its got maybe 73 in her if the limiter doesn't hit.
    Last edited by SKISURFONE; 04-12-2015 at 10:59 PM. Reason: add results

  4. #4
    Got Water!'s Avatar
    Join Date
    Oct 2014
    Location
    Houston, TX
    Posts
    164
    +1
    31
    Sounds like your scom is not working to me. I miss pinned my black wire first time out so I would start there.

  5. #5
    Quote Originally Posted by Jmfmk3 View Post
    No aftermarket intake?? Think you need to add one now that you removed that huge restricter in your manifold
    No still has stock airbox.


    Quote Originally Posted by Got Water! View Post
    Sounds like your scom is not working to me. I miss pinned my black wire first time out so I would start there.
    That's what I was thinking. When I initially got my ski I raced my buddies 13 fzr and he would pull me like a ski to two ski's. Now I pull on him slightly. But it did feel kind of lazy down low. Did you notice anything after the scom install? how was the gas mileage. I noticed the RPM's don't drop either. Were these symptoms similar to what yours had?

  6. #6

    Join Date
    Mar 2014
    Location
    Siesta Key, Fl
    Posts
    1,066
    +1
    155
    SCOM only removes the limiter that drops RPMs after a few seconds of WOT. It would not have any effect on launch or acceleration other than where stock it would back down it will now stay at its real limiter so you keep accelerating)

  7. #7
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,810
    +1
    469
    Your friend's SHO FZR shouldn't beat you with or without SCOM unless his is mod'd...

  8. #8
    Quote Originally Posted by FZeeR View Post
    Your friend's SHO FZR shouldn't beat you with or without SCOM unless his is mod'd...

    He's got 14 ride plate with no shims, open charger, intake grate, gutted water box Riva thru hull and vented front gills, ribbon delete and he's also like 120lbs lighter than me. His ski on some phone apps has gone 71. I'm mostly blown away by how much more gas it wastes

  9. #9
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,579
    +1
    87
    You need to pitch your prop.....
    Quote Originally Posted by d00m View Post
    I just took the ski out today with the ribbon delete and scom i completed this past weekend, the ski chugs alot more gas and the take off doesn't seem as good as it was stock. I only have ribbon delete and scom. Does anyone else know if this is normal or not?

  10. #10
    Got Water!'s Avatar
    Join Date
    Oct 2014
    Location
    Houston, TX
    Posts
    164
    +1
    31
    Quote Originally Posted by d00m View Post
    Quote Originally Posted by Jmfmk3 View Post
    No aftermarket intake?? Think you need to add one now that you removed that huge restricter in your manifold
    No still has stock airbox.


    Quote Originally Posted by Got Water! View Post
    Sounds like your scom is not working to me. I miss pinned my black wire first time out so I would start there.
    That's what I was thinking. When I initially got my ski I raced my buddies 13 fzr and he would pull me like a ski to two ski's. Now I pull on him slightly. But it did feel kind of lazy down low. Did you notice anything after the scom install? how was the gas mileage. I noticed the RPM's don't drop either. Were these symptoms similar to what yours had?
    No, mine just acted like I never installed it with an engine warning horn.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about carb on a 2000 Virage
    By kevinz in forum Polaris Open Discussion
    Replies: 3
    Last Post: 02-29-2016, 08:21 PM
  2. question about decarbonizing on 05 f12-x
    By seadooRXP2590 in forum Honda Open Discussion
    Replies: 5
    Last Post: 06-23-2011, 09:23 PM
  3. Quick question about HOURS on an ENGINE
    By RX-Pike in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-29-2008, 07:48 AM
  4. Newbie Question about handlebars on a 1998 GP1200
    By CJean386 in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 06-01-2007, 12:18 PM
  5. Question about power-on fade
    By lafjax in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-28-2006, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •