Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 52

Thread: svho 6500 rpm

  1. #1
    Chelle's Avatar
    Join Date
    Oct 2008
    Location
    Belgium
    Posts
    252
    +1
    7

    svho 6500 rpm

    As the title says my new fx svho is only getting 6500 rpm's with 36 hours on the clock. Yesterday it was 7000. I've checked the clutch and it's still spinning one way. Any idea's wat it could be?


  2. #2
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    Long shot...check the reverse limiter switch

  3. #3
    Chelle's Avatar
    Join Date
    Oct 2008
    Location
    Belgium
    Posts
    252
    +1
    7
    where can i find that?

  4. #4
    Leendert's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, Florida, United States
    Posts
    918
    +1
    73
    Thats too high rpm for reverse limit.
    sounds like clutch or broken shaft.

  5. #5
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    nope you have a hose lose or off check the hose going to intercooler from throttle body

    I have seen them lose form factory


  6. #6
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    Good call. I forgot about the loose clamps. I found several on ours loose.

  7. #7

    Join Date
    Mar 2014
    Location
    Siesta Key, Fl
    Posts
    1,066
    +1
    155
    Also some have found the clutch to only spin one way and still be bad

  8. #8
    zone5's Avatar
    Join Date
    Feb 2013
    Location
    West of Blue Mountains, Australia
    Posts
    373
    +1
    36
    Yeah, loose clamps first (I had that) and partial clutch failure as second possibility...

    Also, take off the hose 'tween supercharger and intercooler and use a torch (flashlight to you guys) to check the intercooler divider is still in place. It's black rubber and will be visible as you look straight in, if it's come loose it will either obstruct or allow air to bypass the intercooler heat exchanger.

    And of course, replace the hose securely. I check them regularly, and have found the rigid and ribbed j-pipe the SVHO has is less prone to loosening than the more flexible one that was on the SHO.

  9. #9
    Chelle's Avatar
    Join Date
    Oct 2008
    Location
    Belgium
    Posts
    252
    +1
    7
    I Will check al the hoses and clamps today, i hope it's something like that. I'll keep you guy's updatend. Thanks for the advice.

  10. #10
    Chelle's Avatar
    Join Date
    Oct 2008
    Location
    Belgium
    Posts
    252
    +1
    7
    I would like the solve the problem myself because the dealer here at the canary islands isn't capable to fix it. He would probably make it worse.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no boost, 6500 rpm, cant find cause...
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-11-2012, 02:05 AM
  2. seadoo rxp max out at 6500 rpm with WOT
    By rxpsquad in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-20-2012, 10:21 AM
  3. 1996 gtx loses power at 6500 rpm
    By soogtxguy in forum 2-Stroke Performance
    Replies: 22
    Last Post: 07-12-2009, 08:24 AM
  4. Not reving past 6500 rpm's
    By 97XP800 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-18-2007, 10:14 PM
  5. 6500 rpm?
    By needs2bfasterRXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-30-2007, 12:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •