Results 1 to 4 of 4
  1. #1
    yz450f's Avatar
    Join Date
    Aug 2008
    Location
    Long Island NY
    Posts
    657
    +1
    6

    Gp800r first season ride

    It's been a whiles since I rode this thing! Over the winter I put a new solas impellar and wear ring. The stainless wear ring. A Leo's pump wedge pro tec steering nozzle. A modified Jim's plate. And a tdr waterbox. I out it in the water and she ran great but I used a gps app on my phone and it only hit 52 mph. Checked my cables to ensure I was getting full rpm checked my plugs too and the jetting is perfect. It sure felt faster than last year but then again I never ran a gps top speed either lol. Any suggestions or am I expecting too much from my. 800. I thought 55 was obtainable.


  2. #2
    yz450f's Avatar
    Join Date
    Aug 2008
    Location
    Long Island NY
    Posts
    657
    +1
    6
    I also have a 800 intake grate. Pump plug kit flame arrestors and island racing modded carbs with primer kit. Should I swap put the 800 grate for a 1200? Iv heard the 800 grates are a little slower on top

  3. #3
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    The 800 grate is better for top speed in smooth water. What is the pitch of the Solas impeller? In order for us to really help you we will need accurate peak rpm readings from an aftermarket tach. Where is your trim set when you do your speed runs? When the trim is properly adjusted, your highest speed should be attained in neutral. I'm not sure how the TDR waterbox works on an 800...on 1200's on up they don't usually show an improvement over a 1200 waterbox. Do you know the ride plate height on the Jims plate? When installing the pump plug kit, did you use all the pieces? There are 2 flat strips that are intended to go between the shoe and the hull...the mounting bolts go through them. Did you install them? They need to be left out or the pump shoe hangs too low causing a loss of top speed. The shoe needs to be slightly recessed into the hull, if it's flush or hanging below the hull it's too low. Run a search on some of the items mentioned and read the "sticky" sections of the performance and FAQ sections of this forum. Provide some more info, apply what you learn, ask questions here and you'll be all set.

  4. #4
    yz450f's Avatar
    Join Date
    Aug 2008
    Location
    Long Island NY
    Posts
    657
    +1
    6
    Thank you much. I did install a pump plug kit a long time ago so It's possible the show is hanging to low. The impellar is a Solas concord 11/14. And I'm talking with Jim now about ride plate set up.

  5. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ahhhhhhhhhhhhhhhhhhhhhhhhhhh.... first jetski ride of the new season
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 16
    Last Post: 05-13-2012, 06:25 PM
  2. First REAL Ride of the new season
    By lakegastonrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-17-2010, 03:23 PM
  3. First Offical Ride of 2006
    By 05RXPnoob in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-10-2006, 05:38 PM
  4. First successful ride
    By Pettee in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 03-21-2006, 12:51 PM
  5. New Jersey End of Season Ride & Speed Runs...Seaside Hei
    By ramnj in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-23-2005, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •