Results 1 to 10 of 10
  1. #1
    KBizzl's Avatar
    Join Date
    Apr 2015
    Location
    Panama City FL
    Posts
    15

    Speed wheel/sensor issue

    Good morning gents (and ladies). New to this forum and this is my second post so please forgive me if a break any forum protocol. My concern this morning is with my speed sensor/wheel. Although it registers a number on my display, its off by approx. 10-15 MPH. With my 2013 VXR (100% stock) wide open, my speedometer would fluctuate between 40-50 MPH, RPMs were good (redlined). Was the water smooth? Not really, small chop, so I realize with the ski bouncing off the water, the wheel isn't going to have continuous contact, thus fluctuation with the speedometer. GPS was registering 65ish. The wheel itself spins freely, almost too freely if you ask me, but since my ski status is 'newbie', I though I would bring my questions to the experts. Thoughts/suggestions?


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Welcome to GH. Factory speedo wheels suck. If it spins freely, you really just have to live with it. Mine do the same thing.

  3. #3

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527
    Here is the solution to your speedometer problem, This is a GPS module to make it 100% accurate. This product works great, I have bought 4 of them for all my skis. No more wild speedo readings Here is the link http://www.4-tecperformance.com/inde...lb8ds13325eju3 Tommy Jordan

  4. #4
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    I'm inclined to think something is wrong if your speedo is off by that much on a 100% stock ski. Most folks on here have speedo issues with aftermarket ride plates, but that is somewhat expected. A wheel that is off by 10-15mph on a stock ski is just plain weird. My FZR and FX HO are both within a few mph of the gps.

  5. #5
    KBizzl's Avatar
    Join Date
    Apr 2015
    Location
    Panama City FL
    Posts
    15
    Thanks for the quick responses. I agree Mike, its very weird. It almost as if it spins so fast the sensor can't get an accurate reading. Like I said in my original post, it spins freely. Like, I can flick it with my finger and it spins very easily, freely. I like the GPS mod idea 2fast. Did you install them your self? If so, how?

  6. #6
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Quote Originally Posted by KBizzl View Post
    Thanks for the quick responses. I agree Mike, its very weird. It almost as if it spins so fast the sensor can't get an accurate reading. Like I said in my original post, it spins freely. Like, I can flick it with my finger and it spins very easily, freely. I like the GPS mod idea 2fast. Did you install them your self? If so, how?
    FYI both the paddle wheel on my FZ and FX HO spin very easily like you described. I wish there was an easy solution, but still seems weird to be that far off on a stock ski. Maybe check to see how it is mounted? It's only four screws holding it onto the ride plate. You could take it off and reinstall. Not sure it will help though.

  7. #7

    Join Date
    Mar 2014
    Location
    Siesta Key, Fl
    Posts
    1,066
    +1
    155
    You can not go wrong with the candoo gps unit. Have one on my FZS and love it

  8. #8
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    825
    +1
    57
    me too.
    from 10 to 80 is perfect.

  9. #9
    KBizzl's Avatar
    Join Date
    Apr 2015
    Location
    Panama City FL
    Posts
    15
    Got my Candoo GPS speedo for my VXR. Installation and calibration was a snap, but what about the smaller disco'd connector? I should cover it with something to keep moisture out. Zip lock bag and a zip tie at least. Thoughts?

  10. #10
    Quote Originally Posted by KBizzl View Post
    Good morning gents (and ladies). New to this forum and this is my second post so please forgive me if a break any forum protocol. My concern this morning is with my speed sensor/wheel. Although it registers a number on my display, its off by approx. 10-15 MPH. With my 2013 VXR (100% stock) wide open, my speedometer would fluctuate between 40-50 MPH, RPMs were good (redlined). Was the water smooth? Not really, small chop, so I realize with the ski bouncing off the water, the wheel isn't going to have continuous contact, thus fluctuation with the speedometer. GPS was registering 65ish. The wheel itself spins freely, almost too freely if you ask me, but since my ski status is 'newbie', I though I would bring my questions to the experts. Thoughts/suggestions?
    I had a 2007 FX HO that the digital would be off about 15-25 MPH from the needle. The dealer just said that was normal. I was always curious why that would be normal on a stock ski.. I thought it was funny when the digital display said I was going 90 MPH!! Fast ski for non boosted.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200R Top speed and fuel issue
    By 2000gp12r in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 07-05-2011, 11:50 PM
  2. 1997 GP1200 Fuel Sensor issues
    By Sonnamast in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-16-2011, 08:30 PM
  3. Just looking for input on Acura O2 sensor issue
    By sfackett0 in forum Open Discussion
    Replies: 4
    Last Post: 11-26-2009, 05:02 PM
  4. Ultra 08 Heat sensor issue.
    By Skips313 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 03-04-2008, 10:05 AM
  5. Need left sponson for a 2004 GTX and speed wheel sensor
    By JAG in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-28-2007, 04:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •