Results 1 to 2 of 2
  1. #1
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

    New to me 300 4x4.

    Picked this girl up in November went threw it she should be a good work horse around the house and at the races. Added front and rear hitch with winch.



  2. #2
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Va Beach, VA
    Posts
    1,425
    +1
    28
    Nice ride. I once picked up an 05 Sportsman 500 HO for $400 not running. Turned out to be a bad camshaft. The had problems with the metal and ground down the lobes to nothing. Spend a few hundred on a new "Hotcam" and had it running great. Think I sold it for $4k.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to me for electrical wiring
    By lafjax in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-16-2007, 04:31 PM
  2. New to me 95 SLT 750
    By 95SLT750Rider in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-08-2007, 05:26 PM
  3. new to me sl780 issues
    By starflight in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-08-2007, 04:28 PM
  4. need help 96 speedster new to me
    By lp*rp in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-26-2007, 07:45 PM
  5. Got new to me Ski
    By Rodneyae in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-18-2007, 05:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •