Results 1 to 5 of 5
  1. #1
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29

    2010 RXTiS bad green Mass Air Temp Sensor (MATS), throws P0127 code

    The Proof -

    New Blue MATS #420222424

    Click image for larger version. 

Name:	24.jpg 
Views:	173 
Size:	57.3 KB 
ID:	356583

    Just FYI for other guys with the same problem.


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    There was a recall on those sensors for certain models....

  3. #3
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    I bet...cause they suck. So does all the other components that went bad on my ski lol

  4. #4
    SCHNORR12's Avatar
    Join Date
    Mar 2012
    Location
    Lake George, NY
    Posts
    834
    +1
    92
    Quote Originally Posted by XDAILY View Post
    I bet...cause they suck. So does all the other components that went bad on my ski lol
    Are you still having issues?

  5. #5
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Quote Originally Posted by SCHNORR12 View Post
    Quote Originally Posted by XDAILY View Post
    I bet...cause they suck. So does all the other components that went bad on my ski lol
    Are you still having issues?
    Well supposedly, after a very rough 2014 summer with the ski, this is the last code it was holding onto. I'm hoping (praying) I don't hear that damn beeping at all this year after chasing like 5 codes, popping the suspension deck and replacing crap. While I had the deck popped this time I replaced sensors that weren't even bad just because.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Genesis 1200 Ficht repair, bad exhaust temp and air temp sensors
    By mymechanicinc in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-09-2014, 07:57 PM
  2. air temp sensor plug. PLEASE HELP
    By zerowake in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-30-2009, 10:29 PM
  3. Outside air temp sensor
    By jeffsntx in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-27-2009, 02:52 PM
  4. air temp sensor ?
    By syclonedriver in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-17-2008, 10:14 PM
  5. Air Temp Sensor, 2004 GPR
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-08-2007, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •