Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 53
  1. #1
    Slamdcoop0428's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, FL
    Posts
    1,004
    +1
    252

    15 310r scom installed

    Was getting tired of hitting that speed limit feeling so I called jerry and he told me the new riva scoms are a true plug and play for the 310's so I took the plunge and ordered one. Well my best on the Kawi was like 68.7 gps before the scom and now I hit this on Tuesday a few days ago. Was pretty impressed to be honest of the gain I got.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	112 
Size:	37.2 KB 
ID:	356950  


  2. #2
    SD1976's Avatar
    Join Date
    Jun 2013
    Location
    Pensacola,Fl
    Posts
    102
    +1
    21
    How you like the 310R??

  3. #3
    Slamdcoop0428's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, FL
    Posts
    1,004
    +1
    252
    Absolutely love it!

  4. #4
    SD1976's Avatar
    Join Date
    Jun 2013
    Location
    Pensacola,Fl
    Posts
    102
    +1
    21
    I got a 12 300x Looking to get a 310R

  5. #5
    Gsmith88's Avatar
    Join Date
    Mar 2015
    Location
    Li , New York
    Posts
    834
    +1
    104
    Hey quick question , the wire you pulled out of the ecu plug ,and slid into the scom wire (blue i beleive ) , was this fitting kind of loosely? Mine did , hopefully the heat wrap keeps it tight enough.

    Edit : what app is that? Glad you love your 310!

  6. +1 by:


  7. #6
    Slamdcoop0428's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, FL
    Posts
    1,004
    +1
    252
    Quote Originally Posted by Gsmith88 View Post
    Hey quick question , the wire you pulled out of the ecu plug ,and slid into the scom wire (blue i beleive ) , was this fitting kind of loosely? Mine did , hopefully the heat wrap keeps it tight enough.

    Edit : what app is that? Glad you love your 310!
    yep, mine was the same way, I just used the supplied heat wrap. But I zip tied my wires in a way that it won't move or get tugged on in rough water riding.

  8. +1 by:


  9. #7
    Congrats. I only got 71.4 with Riva SCOM 2014 ecu. I'll have to go out and try again. Riding on glass? Trim one click up?

  10. #8
    Slamdcoop0428's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, FL
    Posts
    1,004
    +1
    252
    Quote Originally Posted by pyroseth View Post
    Congrats. I only got 71.4 with Riva SCOM 2014 ecu. I'll have to go out and try again. Riding on glass? Trim one click up?
    In light chop so I think that helped get more of the hull out of the water like 5-6" chop. Trim was all the way up and tucked liked hell lol

  11. +1 by:


  12. #9
    Gsmith88's Avatar
    Join Date
    Mar 2015
    Location
    Li , New York
    Posts
    834
    +1
    104
    Ok thanks

  13. #10
    DH300's Avatar
    Join Date
    May 2013
    Location
    Alabama
    Posts
    1,149
    +1
    217
    Quote Originally Posted by Slamdcoop0428 View Post
    Quote Originally Posted by pyroseth View Post
    Congrats. I only got 71.4 with Riva SCOM 2014 ecu. I'll have to go out and try again. Riding on glass? Trim one click up?
    In light chop so I think that helped get more of the hull out of the water like 5-6" chop. Trim was all the way up and tucked liked hell lol
    Try the trim with 1-2 clicks up next speed runs and see what happens. That is where I saw the best results.
    Last edited by DH300; 04-24-2015 at 11:10 AM.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 310r scom install
    By yamaha1390 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 10-02-2016, 04:20 PM
  2. scom install instructions
    By mattydipps in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-11-2014, 02:44 PM
  3. Scom install?
    By MONSTERMATT in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-09-2013, 12:09 PM
  4. SCOM install query (not working)
    By dw_1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 10-25-2012, 03:38 AM
  5. Replies: 10
    Last Post: 09-27-2011, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •