Results 1 to 5 of 5
  1. #1

    Question about bad stator/magneto in Polaris SLT 750

    Hello, I had a quick question about the likelihood of a bad stator/magneto. I have no spark on all 3 cylinders and I have replaced the battery and the whole electrical box including CDI, still the same problem. I am wondering if the new (used) CDI that was "good" really isn't good (found a fried ground wire to the box shown in my other post).

    I set the spark gaps very small to see if the system was functional but weak or completely non functional. Still got nothing. Do you think I should go after the magneto/stator now or find a way to try one more known-good CDI first in the chance that I replaced a bad one with another bad one that was only thought to be good?

    Thanks in advance, you all rock and your help is much appreciated!


  2. #2
    Update: Tested the stator with my Digital Multi Meter and found it is a faulty stator with a short to ground. Now to get it pulled...

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by SlpFirehawk415 View Post
    Update: Tested the stator with my Digital Multi Meter and found it is a faulty stator with a short to ground. Now to get it pulled...
    Which stator wire was measured as shorted to ground?

  4. #4
    It was... drumroll... Solid Blue, Stripe Blue, Stripe Red. Here is a picture of what I found when I took the stator off after diagnosing with a digital multimeter. Note the wire wrap on the right set of wires looking like a torch was put to it. We now have spark!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0861.JPG 
Views:	73 
Size:	134.2 KB 
ID:	357458  

  5. #5

    Join Date
    Jul 2015
    Location
    Cleburne Texas
    Posts
    33
    Were u able to pull off the stator without pulling the motor? I may have a bad stator that I'll b working on. Not really sure how to test the stator before pulling it off

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. do i need to split cases in polaris slt 750 with hole in first piston
    By Bmwcrazyman in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-03-2013, 07:50 AM
  2. Replies: 0
    Last Post: 05-25-2010, 04:27 PM
  3. '95 Polaris SLT-750 Question
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 12-10-2007, 10:24 PM
  4. Question about red blinking light in digital display
    By diesel359 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 11-13-2007, 09:42 AM
  5. Question for a Polaris slt 750
    By Rodney in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 08-10-2007, 12:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •