Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2010
    Location
    Wichita, Ks.
    Posts
    248
    +1
    1

    Need HELP on a PTO housing issue

    I have a 2006 RXP and I broke my driveshaft and it did damage to the opening on my PTO housing where the driveshaft slides in. I purchased from a member a PTO from a 2008 RXP. I have installed this and have tried to reinstall new driveshaft and it is not working, so my question is is there a differnece in these 2 PTO housing that does not allow the shaft to go in as far as a 06 PTO housing? Am I missing something? Thanks for your help in advance.


  2. #2
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    Just looking at OEM parts list there definitely is a different part number for 2006 RXP/ RXT 420812622
    2008 RXP 215 RXP255 420812623

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    There is probably a broken piece still in the end of the crank shaft

  4. #4
    Banned User
    Join Date
    Nov 2014
    Posts
    200
    +1
    13
    Does anyone have a service manual picture of the actual area in which the driveshaft sits into the crank shaft?

  5. #5
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    The rubber bumper may be smashed inside the end of the shaft

  6. +1 by:


  7. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Click image for larger version. 

Name:	image.jpg 
Views:	40 
Size:	134.1 KB 
ID:	357276

    #9-11

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. guys, I really need help on this one
    By maguyver in forum Yamaha Old School Skis
    Replies: 19
    Last Post: 02-11-2008, 10:08 PM
  2. Need Help on 02 virage 700cc
    By jeffholloway96 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 12-19-2007, 07:48 AM
  3. Need help on a 440!!
    By thesepaperwings in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-15-2007, 08:36 AM
  4. Need Help On Motor Mounds
    By wsony13 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-26-2007, 10:54 PM
  5. Replies: 11
    Last Post: 08-25-2006, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •