Results 1 to 10 of 10
  1. #1
    JP_RACING_INC's Avatar
    Join Date
    Jul 2014
    Location
    FT. MYERS FL
    Posts
    269
    +1
    26

    Unhappy 2008 RXPX feels loose???

    As I'm approaching higher speeds around 72+ the ass end of the ski tends to feel like it pops out of the water like if it loses suction and starts to slide lightly left and right, according to my gps it begins to lose speed as if I'm dragging something through the water. I've tried searching for info on the forum but haven't found anything. Wondering if anyone has experienced this and what you guys would recommend to resolve the issue. Thanks guys!


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What mods do you have?

  3. #3
    JP_RACING_INC's Avatar
    Join Date
    Jul 2014
    Location
    FT. MYERS FL
    Posts
    269
    +1
    26
    Riva 4in kaniflex
    solas 15/20
    83mm rxp nozzle
    2°wedge with riva extension rod
    tdr water box
    riva thru hull
    r&d grate
    opas block offs
    filled plate and grate holes
    Last edited by JP_RACING_INC; 04-29-2015 at 12:19 PM.

  4. #4
    To much power, she's trying to take flight

  5. +1 by:


  6. #5
    Could it be your OPAS not raising fully. They could be gunked up / full of sand etc. Feel them, just slide them up and down and check if they're sliding free. It can give a loose swaying feeling to the back end.

  7. #6
    JP_RACING_INC's Avatar
    Join Date
    Jul 2014
    Location
    FT. MYERS FL
    Posts
    269
    +1
    26
    opas has been removed forgot to add that to the mod list.tornado,i wish she was taking flight travis lol

  8. #7
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,479
    The large pump tunnel of the X model won't like the smaller 83mm and a wedge. It may be trying to stuff at that low of a speed. I've never seen one stuff so quickly but the variables are there. Pop the stock 87mm back on (if you have a 15/22 impeller to keep revs correct) and see if that helps, or remove the wedge and run it to see if the 'lifting' feeling goes away. Good luck!

  9. +1 by:


  10. #8
    mikebigs's Avatar
    Join Date
    Mar 2012
    Location
    River Crew CT
    Posts
    56
    +1
    3
    check to make sure grate isnt bent

  11. #9
    JP_RACING_INC's Avatar
    Join Date
    Jul 2014
    Location
    FT. MYERS FL
    Posts
    269
    +1
    26
    im going to try and remove wedge tomorrow and see if that stops the lift in the rear end.

  12. #10
    Do a GPS run and see if you lose anything with the wedge absent

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 2008 Rxpx 11800.00 Each
    By ALOHR in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 06-18-2008, 08:10 AM
  2. 2008 rxpx sucked up rocks
    By stevierxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-02-2008, 01:47 PM
  3. 2008 Rxpx For Sale 11900.00 Ski Is New 1 Hour
    By ALOHR in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-22-2008, 12:48 AM
  4. 2008 Rxpx For Sale
    By ALOHR in forum Sea Doo Classifieds
    Replies: 15
    Last Post: 05-06-2008, 07:55 PM
  5. 2008 rxpx last year for rxp hull?
    By superstock1986 in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-08-2007, 08:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •