Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1

    Does this prop look bad?

    In the middle of chasing down a 0-25 cavitation problem. Had the dealer replace the wear ring while it was getting winterized. Did nothing. Decided to put a new Carbon seal and boot etc on. I got everything pulled apart and saw the prop. Seems like it could be the problem but I'm new to this. Any advice on if it's ok or not would be great. Thanks
    Click image for larger version. 

Name:	image.jpg 
Views:	197 
Size:	89.4 KB 
ID:	357320


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Theres a good portion of your cavatation...IMO that prop is garbage.....Either sent it to Impros to have it fixed ,or see if somebody has one laying around they want to sell you cheap...Either way,I would be replacing that prop..


  3. #3
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Looks like your pump might be warped..Hard to tell from the pic without a close up.....

    But yes, the prop is a major factor in your cavitation...

  4. #4
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    they don't get much worse than that and still work

  5. #5
    What pisses me off is I had this in the shop at the end of the season for the cavitation issue. They replaced wear ring and said it was fixed. Took out last weekend and nope. I pull the pump and see this. How would the seadoo dealer miss this? Now I got the driveshaft pulled, Carbon seal and boot, hoses exhaust supercharger all removed, when this was pry my problem. Looks loke I'll be paying next day air on a prop now because we have a trip planned sAturday.

  6. #6
    Ken62465's Avatar
    Join Date
    Apr 2011
    Location
    Gardner, MA
    Posts
    582
    +1
    48
    I'd also check the radial play in that shaft also...should be zilch. Pics are hard to tell but looks to me like a uniform wear around that liner that could be a bad bearing or judging from the boo boos in those leading edges it looks like someone rides a bit close to shore which could also chew up your prop and liner. Dealer replaced wear ring and didn't spot that prop?

  7. #7
    Yupp they said it was fixed and running like a top. I bought the ski on July 3rd last year. Had it out once and it was cavitating then the ecm went. Took to dealer they replaced the ecm and put a new wear ring on and said it was fixed...nope.

  8. #8
    I can't believe they wouldn't try to get me for more. Sad thing is my buddy was gonna buy a '15 gtx limited 215 from them last weekend but they were priced 200 over msrp and they wouldny budge on price after his dad bought a 40,000 dollar pontoon the weekend before. We ended up driving 2 hrs and paying 650 under msrp with a dealer we have never been to

  9. #9

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    the real question is: where is the original 04 GTX 185 aluminum jet pump and do you really have a 185 impeller in that plastic pump housing or is it a 155 prop? It is very difficult to tell by looking at the impeller as to what it is as the casting numbers are the same between the 155 and the 185s. Seadoo ran 2 impellers for the 04 185 and the later version was a MUCH better all around impeller choice. The impeller that you have pictured is obsolete by seadoo for good reasons.

  10. #10
    RXP 260 X Short Course Veteran RXP244's Avatar
    Join Date
    May 2007
    Location
    Auckland, New Zealand, New Zealand
    Posts
    1,244
    +1
    104
    Quote Originally Posted by jim View Post
    the real question is: where is the original 04 GTX 185 aluminum jet pump and do you really have a 185 impeller in that plastic pump housing or is it a 155 prop? It is very difficult to tell by looking at the impeller as to what it is as the casting numbers are the same between the 155 and the 185s. Seadoo ran 2 impellers for the 04 185 and the later version was a MUCH better all around impeller choice. The impeller that you have pictured is obsolete by seadoo for good reasons.
    How do we know it's an 04. And didn't 03 GTX 185's have plastic pumps. Then in 04 they went 215 and got Alumunium pumps?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does this piece look familiar?
    By Power_Man in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-29-2015, 10:20 PM
  2. How bad does this damage look?
    By wisconsin_quat in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-01-2013, 11:06 AM
  3. Cavitation issues, how bad does this impeller look?
    By Ryan in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-26-2013, 01:17 PM
  4. new to the sc scene does this all look normal?
    By bigo in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-31-2011, 07:45 AM
  5. How bad does this Greenwheel Look?
    By ADAMBOMB in forum 4-Tec Performance
    Replies: 49
    Last Post: 09-12-2008, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •