Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Sharkdiver1125's Avatar
    Join Date
    Apr 2015
    Location
    Chesapeake bay MD
    Posts
    156
    +1
    23

    Question 2012 Rxtx et137 not making enough boost

    Im having an issue with my 2012 Rxtx 260. I am vtech tuned 8350 rpm with a et137 supeecharger wheel and lots of other bolt on supporting mods, the first day I put the new charger in it made 14lbs of boost. After 3 or 4 passes it started to feel slow and was no longer making as much boost, I was very Low on fuel and thought it may have been sucking air. I filled it up with fuel and went out the next day and still feels sluggish off the line and is only making 11psi or so of boost At 8200 rpm. I have an aftermarket intercooler and the afr is 11.7-12.0 at wot so It seems i haven't ran out of injector. (Still have stock 48s) the top speed of the ski is still quite impressive, 78.7 GPS 60 defree ambient temperature, but only
    making 11 pounds of boost. When the ski is out of the water and I blip the throttle it will hit the 8350 rev limiter and still only make 11-12psi. Just out of curiosity I put a barb fitting right before the throttle body and checked the boost there the same way, just reving it out of the water, and it made 15psi before the throttle body. I just took off my intake manifold to inspect for cracks or leaks and everything looks fine. Is it maybe possible the ski is sensing the injectors Are at 100% duty cycle and is closing the throttle body? With the ski off I have visually checked and confirmed the throttle is opening all the way. Somebody help


  2. #2
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    ANY charger needs 2 to 3 ft lb torque higher slip moment then the boost they r trying to achieve.....so if u seen 14 psi boost u need 16/17 ft lb slip to hold and maintain that boost level & I would bet its not there in the charger slip moment so check it out.....GOOD LUCK!!!!!!!!!!

    p.s. NEW larger chargers lose SLIP FAST on break in!!!

  3. #3
    This will be almost impossible to diagnose without data logging.

  4. +1 by:


  5. #4
    Sharkdiver1125's Avatar
    Join Date
    Apr 2015
    Location
    Chesapeake bay MD
    Posts
    156
    +1
    23
    I have checked the slip And the slip moment is 15-16 ftlbs

  6. #5
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by Sharkdiver1125 View Post
    I have checked the slip And the slip moment is 15-16 ftlbs

    sounds decent but 1/2 ft lb above isn't enough IMO 2/3 is minimum settle point in my book.......either way I would think 14 shoudnt be a problem to b seen again if it does have that still amount of slip...GOOD LUCK!!!!!!

  7. #6
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,351
    +1
    105
    If the slip is at 15 - 16 ft/lbs, you should be good. That's what I set mine at and never had a problem. Might want to check somewhere else for the problem.

  8. #7
    Does this ski have an oil catch can? Has this intercooler ever had oil going thru it? If it did, was it cleaned?

    Andy

  9. #8
    He does have a catch can and the intercooler is brand new

  10. #9
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    627
    +1
    22
    You split your intake manifold

  11. #10
    Sharkdiver1125's Avatar
    Join Date
    Apr 2015
    Location
    Chesapeake bay MD
    Posts
    156
    +1
    23
    Do you know where they split, I have removed the manifold and can't see any Cracks or splits

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXTX not running right please help
    By Sharkdiver1125 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-22-2015, 11:07 AM
  2. Can I make the riva thru hull fit my 2012 rxtx?
    By JohnnyG. in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-20-2012, 11:34 AM
  3. is honda not making a pwc in 2009
    By Bulldogs101 in forum Honda Open Discussion
    Replies: 4
    Last Post: 10-28-2008, 10:59 AM
  4. Why not make a metal 4" intake ???
    By MIARider in forum 4-Tec Performance
    Replies: 110
    Last Post: 08-19-2008, 12:25 PM
  5. RXTX VTS Not working
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-27-2008, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •