Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    May 2007
    Location
    raleigh,nc
    Posts
    20

    slow speed on sea doo

    I have a friend with a 2008 seadoo rxtx 255. the ski is running 8000 rpms but the ski is only running 55mph. I believe this ski should be running around 68 to 70. my first thought was a prop or pump liner issue. but all looks fine. ive rode skis with bad props before and there is a feeling like a slipping clutch but this ski isn't doing any of that. does anybody on here have any idea what it could be?


  2. #2
    connorrxp's Avatar
    Join Date
    Dec 2014
    Location
    ontario
    Posts
    680
    +1
    83
    Check the supercharger slip, if the charger hasn't been rebuilt in 100 hours it could be failing, check the wear ring around the impeller too, also if he has a strainer going to his intercooler make sure its not plugged with debris and that its turned on.

  3. +1 by:


  4. #3
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    250
    +1
    4
    check the oil level

  5. #4

    Join Date
    May 2007
    Location
    raleigh,nc
    Posts
    20
    I checked the wear ring and the prop and it all looks fine if it was the supercharger would it still get to 8000 rpms?

  6. #5
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,353
    +1
    971
    take the pump out and put a feeler gauge between the impeller and wear ring, post a pic!

  7. +1 by:


  8. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Any mods done to it? Could it be all over the limiter, with the wrong prop size?


    Could be a bad carbon seal / or engine mounts could be broken & sucking air from hull.
    Last edited by psycho rxp; 05-01-2015 at 12:15 PM.

  9. #7

    Join Date
    May 2007
    Location
    raleigh,nc
    Posts
    20
    100% stock

  10. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    How are you checking the speed? How does it compare speed wise to other skis you might ride with?

  11. #9
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,180
    +1
    98
    People, PLEASE read the OP's post completely before commenting. Any one that talked about this being an engine/supercharger/intercooler issue, step aside.
    The engine is performing just fine, 8000 rpm is about right.
    This is a propulsion issue, be it cavitating, bad prop, wear ring, carbon seal etc.
    Could be as troyheb says, just a speedo inaccuracy issue.

  12. #10
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Splines at prop end letting go maybe??? Bearings in pump going bad?? Would start by pulling pump. Sounds like something back there is not right.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone work on sea doos in mass
    By massguy in forum Northeast
    Replies: 5
    Last Post: 01-22-2010, 12:15 AM
  2. Honda connecting rod on Sea Doo 951 crank?
    By Gappa in forum 2-Stroke Performance
    Replies: 11
    Last Post: 04-28-2008, 10:44 PM
  3. Jerry and Shootout on Sea Doo Website
    By SearayEX12 in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 04-12-2008, 09:19 PM
  4. Sea Lion on Sea Doo.....
    By liner911 in forum Videos & Pictures
    Replies: 4
    Last Post: 03-01-2008, 11:40 AM
  5. Do they have Black Friday Sales on Sea-Doo's?
    By 96gtxdoo in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 11-25-2006, 05:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •