Results 1 to 7 of 7
  1. #1
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98

    2014 Seadoo GTi vibration issue

    Buddy of mine has a 2014 Seadoo GTi that after a prolonged wake zone, idle or at times on start up with vibrate violently and not rev out. Sounds loud and horrible he says. Will stop and restart the engine several times for issue to go away. Took to dealer and nothing in the pump. Carbon ring ok and tolerance ok with wear ring. Ski has same top end, but he feels lost some take off. Dealer has it again. Any ideas?


  2. #2
    Could it be broken engine mount or engine needing aligned?

  3. #3
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Not sure. Has 63 hours and the dealer did check the carbon seal and said it was ok.

  4. #4
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Any ideas guys? After prolonged idle or upon some starts, ski has no power and vibrates/ shakes violently. After several attempts to restart, runs as it should. Dealer checked the pump and carbon seal. Still does it.

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    fuel pump?
    does it smell rich?
    look at the plugs, do they all look the same?

  6. #6
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Will mention it to him. At the dealer now. They can't get it to do it. Does it now and then, but always at the worst time lol

  7. #7
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    245
    +1
    35
    Check engine mounts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 seadoo gti p0326 issue help
    By Nrbball4391 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-27-2013, 12:37 AM
  2. 2003 seadoo gti rfi issue
    By Ladykarter in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-17-2013, 04:37 AM
  3. Seadoo GTI Starting issues
    By impulsive in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-07-2012, 06:52 AM
  4. 2001 Seadoo GTI starting issue
    By leedanger in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-31-2011, 07:17 AM
  5. 2000 Seadoo GTI WOT Issue - Acting like it has a rev limiter?
    By YoCoLifSavr in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 05-12-2011, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •