Results 1 to 3 of 3
  1. #1
    Banned User
    Join Date
    Sep 2014
    Location
    NEW JERSEY
    Posts
    380
    +1
    5

    2004 Rxp gauge cluster

    I recently bought a 2004 Rxp. I noticed the gauges had water behind the glass. When I put the key on. They didn't move, light up. Nothing. I found a white fuse that was bad, I fixed that an then when I put the key on, I got a real loud an long beep but still nothing from the cluster it self. Any input ?


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    The loud beep could mean the key you tried is not programmed to your ski.

  3. #3
    Banned User
    Join Date
    Sep 2014
    Location
    NEW JERSEY
    Posts
    380
    +1
    5

    Cluster

    Quote Originally Posted by JFizzleJR View Post
    The loud beep could mean the key you tried is not programmed to your ski.
    The key is programmed to the ecu. It starts the ski

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD 05 RXP Gauge cluster
    By Gus13letter in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 07-24-2012, 10:52 AM
  2. WTB Rxp gauge cluster wanted!! Urgent!!
    By tocullo in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 06-27-2012, 10:08 AM
  3. WTB 06 rxp gauge cluster
    By old school gp in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-14-2011, 02:19 PM
  4. 2004 rxp gauges
    By goingfast92 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-16-2010, 05:47 AM
  5. 07 RXP gauge cluster
    By Superunatural in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-04-2008, 08:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •