Results 1 to 10 of 10
  1. #1

    1997 seadoo gtx 787 wont stay running :'(

    Hey everyone im new to this sport and i purchased a 1997 seadoo gtx 787 last year and when i first bought it, it wouldn't go faster then 60kmh. So i decided to rebuild the carbs and change the fuel lines because they had the grey lines. I took the ski out yesterday and it will run fine for 5min then the engine just cuts out while im doing 80kmh . I restarted it again and it would go for a min then cut out again, and last time i restarted ( getting closer to the dock) it was running a little rough wouldn't let me go wot...and my lcd says 12v low and i have a brand new battery in it this year. Last year it also said 12v low but was running all day but limited to 60kmh cuz the gunk in the carbs...plz help

    I checked the compression and one cylinder is at 145psi and the other at 110psi, ao i opened the top end up and heres a pic(dont know how to post yet), looks like theres no oil in there and the spark plug is grey on the 110psi plug and the other is choclate brown.


  2. #2
    Heres the pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20150507_144411.jpg 
Views:	90 
Size:	70.2 KB 
ID:	358128   Click image for larger version. 

Name:	20150507_144402.jpg 
Views:	146 
Size:	87.2 KB 
ID:	358129  

  3. #3
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    You have a couple different problems. 12v low is usually a sign of a failed rectifier on these. The running and cutting out was probably because it was lean seizing on you OR maybe your oil injection pump has quit. It's hard for me to tell in the pics but there is a definitely an issue with that front cylinder

  4. #4
    Ok, thanks for the quick reply. one cylinder has oil(145psi) and looks and runs great the other looks dry(110psi) why is one side getting oil and not the other side? Where would i check for this or is there a oil adjustment somewhere?

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    It could be getting oil and not enough fuel too. Oil pump can be taken off and tested. I use an old bolt that I cut a slot into chucked up in my drill. I believe you will run the drill in reverse. Use a piece of tubing full of oil and run the drill while holding the lever wide open on the pump. You should get a drip out each line about every second. Contrary to popular belief they DO go bad sometimes.

  6. #6
    Ok so your saying that even tho 1 cylinder is getting oil the other one isn't because of the oil pump? And also could it do anything with the low speed and high speed screw? Because this just started after i cleaned the carbs.

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    Definately could. If the carbs were still dirty or badly adjusted it could run lean.

  8. #8
    Yes i didnt adjust the screws yet im going to try that, is it factory settings then or should i adjust them differently? ?

  9. #9
    Ryguy425425's Avatar
    Join Date
    Jul 2012
    Location
    Saint Croix, New Brunswick, Canada
    Posts
    59
    +1
    4
    I'd place my money on your main problem being the rectifier. I had similar symptoms in my '97 GTX. 12v low warning, dieing if I gave it more then 3/4 throttle, running rough, then finally frequent stalling. I think I paid $25 for a replacement on eBay, though the cheap units are hit and miss so most people will recommend OEM Seadoo.

  10. #10
    Quote Originally Posted by Ryguy425425 View Post
    I'd place my money on your main problem being the rectifier. I had similar symptoms in my '97 GTX. 12v low warning, dieing if I gave it more then 3/4 throttle, running rough, then finally frequent stalling. I think I paid $25 for a replacement on eBay, though the cheap units are hit and miss so most people will recommend OEM Seadoo.
    Ok I'm going to replace that too, I was gonna look into it too. Thanks for the help guys I'm gonna let you know what happens after the weekend I work long hours and probably won't be able to touch the ski till Monday

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Seadoo GTX runs good on 1/2 choke only
    By gpshogan in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-13-2016, 10:22 AM
  2. problem with mys seadoo RXP-X 2008 ,starts and stalls.Wont stay running.
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-01-2016, 10:53 PM
  3. 2005 Seadoo 3D wont stay running
    By abuzar1 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-09-2014, 10:48 AM
  4. my 97 gtx wont stay running on water
    By provo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-01-2011, 09:15 AM
  5. 1996/1997 SeaDoo GTX/787 Motor Parts
    By Crazy685 in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 12-17-2008, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •