Results 1 to 1 of 1
  1. #1

    hi everyone im new here and new to ski's i need help pls

    hi my name is dan

    right where to start, I have only just brought a sea doo wake 155 (2007) had it checked out before i got it and on my first outing having fun and after about45 mins on it and out of no where the ski just shut down i tried starting it and it was just clicking an wouldn't do anything got towed back put it on charge and after an hour on the battery charger it started so i took it in got it look at again turns out the stator was f**ked so i pulled the engine out changed it cleaned all terminals when engine was out now its back running but im having the same problem as its not charging i changed the reg/rec and still the same thing and im also when i put the key/lanyard on and i get two beeps and then one long beep that went for about 5 seconds please can someone help me
    Battery volts 12.82 cranking volts 11.1
    UPDATE now after cleaning all the connectors and testing all fuses and have 12.7 at the battery i get no beeps and it wont crank over
    Last edited by Mad dog85; 05-09-2015 at 08:27 PM. Reason: more info


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 07-13-2015, 09:34 PM
  2. New here and looking to buy my first PWC.
    By DrivingZiggy in forum Open Discussion
    Replies: 0
    Last Post: 05-04-2013, 03:25 PM
  3. New to 1996 HX rebuild need help
    By orangefinger in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 01-13-2012, 03:05 AM
  4. im new to all of this lol
    By joe palmer in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-30-2011, 07:32 PM
  5. Replies: 16
    Last Post: 04-17-2007, 11:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •