Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990

    Anyone ever snapped an R&D billet shaft?

    I thought the R&D shafts were bulletproof?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1340.jpg 
Views:	69 
Size:	112.8 KB 
ID:	358420  


  2. #2

    Anyone ever snapped an R&D billet shaft?

    Happens when the nut gets over torqued.. But all shafts have broken. There is no bulletproof shaft.

  3. #3
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    It wasn't over-torqued but I would think it the nut were over-torqued, it would have snapped right below the threads like the other cases I have seen.
    Last edited by Ski Hacks MG; 05-10-2015 at 05:41 PM.

  4. #4
    Contact Glenn to see if he'll replace it..

  5. #5
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Is Glenn a member here?

  6. #6
    WP3223's Avatar
    Join Date
    Jun 2011
    Location
    Boynton Beach, FL
    Posts
    895
    +1
    93
    Quote Originally Posted by CCW View Post
    Is Glenn a member here?
    You can call Glenn directly at R&D performance.

    http://www.rd-performance.com/contact/index.asp

  7. #7
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    649
    +1
    88
    From a mechanics standpoint, you would expect it to shear right where it did. What wheel were you running at what RPM? Hopefully they'll help you out with a new one.

  8. #8
    WP3223's Avatar
    Join Date
    Jun 2011
    Location
    Boynton Beach, FL
    Posts
    895
    +1
    93
    Quote Originally Posted by CCW View Post
    I thought the R&D shafts were bulletproof?
    There are a whole lotta guys throwing crazy boost & rpm's at these shaft's - but there can always be that one bad apple..
    Last edited by WP3223; 05-10-2015 at 06:51 PM.

  9. #9
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Quote Originally Posted by HydroStream6 View Post
    From a mechanics standpoint, you would expect it to shear right where it did. What wheel were you running at what RPM? Hopefully they'll help you out with a new one.
    8640rpm's on a C3-11 wheel. I only made one full throttle run today and about 2-3 minutes later, noticed the white smoke. Shaft, wheel and bearings have been in for 1 year (15 hours or so).

  10. #10
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    649
    +1
    88
    Ouch that bites. Well, see if R&D can help out. I run a C3 on a stock shaft.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone ever put an outboard on an empty hull?
    By stimpsonjcat in forum Polaris Open Discussion
    Replies: 18
    Last Post: 09-24-2012, 09:25 PM
  2. Has anyone ever payed for an image?
    By two2curupt in forum Open Discussion
    Replies: 7
    Last Post: 03-30-2009, 07:07 PM
  3. Anyone ever heard of an R&D Ride Plate cracking?
    By akjose in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 12-28-2008, 03:09 PM
  4. Anyone ever installed a rear step on an RXP?
    By sammibelle in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-30-2007, 11:49 AM
  5. Has anyone ever filled in the two outer channels on an R & D plate?
    By onefastgp in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-26-2006, 08:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •