Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    200
    +1
    2

    I need some help with an issue today

    2011 RXT-X 260

    When I hit the throttle I am not going pass 5mph or so, its reving up but alot of vibration in the haul. I looked under the boat and nothing is stuck in the grate or near the prop. I remember racing RC boats and when the flex (drive shaft) shaft come loose it would almost do the same thing when on full throttle it goes no where but near idle I can move. Any help would be appreciated.


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Trash or debris in the grate, prop or pump. You just cant see it. Tip the ski up on the side and you will find it.

  3. #3
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Could be some small piece of debris stuck on the back side of an impeller blade, or the wear ring is shot, or the worst case is a stripped drive shaft....

  4. #4
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    321
    Make sure you didn't blow the venturi nozzle apart.

  5. #5
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    200
    +1
    2
    I was having problems near the shore with my battery terminal coming loose. After I started the ski it was near shore in the sand but I washed the ski down looked thru the grate with a flash light and looked from the backside in thru the prop and I dont see nothing in there. I was running perfect until I started and left the shore

  6. #6
    The exact same thing happened to mine the other day! Hit the throttle and it shakes and vibrates like a MOFO!!!! I finally got pissed about going 3-5mph and canned it for 3 seconds, and whatever was blocking it came loose and it took off. That was after about 15 minutes of the shake and going 5.

  7. +1 by:


  8. #7
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    200
    +1
    2
    I didnt want to mess anything up in case it was something stupid, I just crusied back to the shore. I am sure its something small I am just new to this and still learning.

  9. #8

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    311
    +1
    31
    I would not recommend doing this. Revving the engine with an object on the impeller can end up with a bent drive shaft. Take it ot shore and remove the debris.

  10. #9
    highboostrxt's Avatar
    Join Date
    Mar 2015
    Location
    Tampa FL
    Posts
    200
    +1
    2
    No I didnt rev it at all when I felt the vibration. I looked tonight when I got back to the shop but nothing

  11. #10
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Look better.

  12. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought an 05 GTX last fall and need some help with a squeal
    By Doug Doty in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-24-2013, 06:16 PM
  2. Need some help with gas valves
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 08-13-2007, 11:54 PM
  3. Need some help with a 650 LX
    By utahnewbie in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-04-2007, 11:59 PM
  4. I Need Some Help With My Shark !!!!!!
    By sleblanc in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-20-2006, 03:17 PM
  5. Need some help with adjust a thrust
    By AaronC in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2006, 06:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •