Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Banned User
    Join Date
    Sep 2014
    Location
    NEW JERSEY
    Posts
    380
    +1
    5

    Oil out the dip stick and breaking up ?!?

    Long story short...

    i I bought a 04 Rxp, kid said rpms died on him an he couldn't get it to start. So he sold it, To me.
    i do couple test, compression, psi test on the antifreeze bottle.. Both checked out good but when I pulled the dip stick, it was milky.

    so I got as much as I could out.. Put fresh oil in... Ski starts right up no problem... Only thing is that oil is just rushing out the dip stick hole and when I rev it up it breaks up an kind of Boggs down, if I just hit the start button. It idles and sounds perfect but once it starts to build pressure, it makes it pours out the dip stick hole

    is that the vent valve ? And also would that make it break up as its doin ? Thanks in advanced


  2. #2

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    front oil pump maybe?

  3. #3
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    Sounds like the front valve is not working. Put the lanyard on, it should go click, pull the lanyard and it should go click about 10-15 sec later. If you don't hear it, check that valve.
    Also, press the SET button 5X and it will display if any fault codes are stored.

  4. #4
    Riko's Avatar
    Join Date
    Jul 2014
    Location
    Greece,Patras
    Posts
    103
    +1
    6
    To my knowledge milky= coolant with oil mixed up.Also mixing oil with coolant causes a higher viscosity fluid and builds more pressure trying to turn it around the engine passages

  5. #5
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    sounds like coolant mixing somewhere in the cylinders and has been. If thats the case then the rings may be the issue now along with the coolant leak

  6. #6
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    Now hold on, he said it was milky and he changed it, he did not say it was milky again. Also he pressure tested the cooling system and it had no issue. So until he get back with its it's still getting milky, or the coolant is dropping, we cannot know.
    The previous owner (kid) may have sucked up water for all we know.

  7. #7
    Banned User
    Join Date
    Sep 2014
    Location
    NEW JERSEY
    Posts
    380
    +1
    5
    Well I got out as much as I could an then my plan was to start the engine, let it run. Change the oil again an so on an so on until I get it all completely out. But when I started it, I noticed oil was coming out the dipstick. It wasn't Doin that when I first got the ski home an fired it up. The minute I got home I put a jump box on the ski an it fired right up but I checked the dip stick an that's when I noticed it was milky so then I took off the oil cooler an found the leak in it, I put a good oil cooler on an then o sucked out all the old oil (I thought it was all but all I got out was roughly 2 quarts, every which way I put the hose in to suck it out I couldn't get it all out so I figured that was it. But then I added oil an put it all back together an it fired right up again, I revved it a little an it started breaking up and then I noticed oil shooting out the dipstick an then it literally poured out like I tipped the ski up side down. Compression is good

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    It sounds like you have an issue with crank case ventilation (tops valve). BRP changed the set up in 06 for some reason... probably cost. However.... that would be the place to start investigating.

  9. #9
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,634
    +1
    159
    There's a fuse for me it on the mpem, I had a customer swap the connectors for the tops and oil blow by sensor on the front of the motor, tops stopped working and it would push the dip stick out or if I removed the oil cap pressure would release. It took some digging but there's a fuse for it

  10. #10
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,634
    +1
    159
    There's a fuse for it on the mpem, I had a customer swap the connectors for the tops and oil blow by sensor on the front of the motor, tops stopped working and it would push the dip stick out or if I removed the oil cap pressure would release. It took some digging but there's a fuse for it

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil coming out of dip stick
    By Cooler in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-01-2015, 08:28 PM
  2. Oil Blowing out the dip stick
    By Dairrell in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 02-26-2014, 07:41 PM
  3. kawasaki 300x blowing oil out the diverter valve help!!!!!!!!
    By lex08gsr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 67
    Last Post: 05-30-2012, 02:12 PM
  4. OIL coming out of Dip stick
    By Lbaronio in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-01-2012, 06:35 AM
  5. 2007 stx12f blowing oil out the overflow ?
    By chris alix in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 07-18-2010, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •