Results 1 to 4 of 4
  1. #1

    Polaris SLT 750 No Spark - Seeking Electrical Repair - Melbourne FL Area

    Does anyone know someone that would work on my 95 SLT 750 in or around the Melbourne, FL area? It has a like new engine but stopped getting spark awhile ago and has been sitting ever since. Every time I try and crank it the MFD display blinks red and is mostly unreadable. It used to work fine. I tried the little stuff (new battery, spark plugs, trimming wires, etc.) but I don't have the time or electrical knowledge to pursue it any further. At this point, I really just want to find someone to work on it or sell it if I can. I called a local shop and they said they wouldn't touch it. Thanks for your help.


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Do you have the plastic battery cover installed between the battery and electrical box? Take a quick look at the wire harness running from the ebox to the front of the motor. Pull the plastic loom open and look at the wires for any sign of burning or charring.

    Pretty simple quick checks. I would look at it for you, but a bit too far away....

  3. #3
    Quote Originally Posted by BlueFishCrisis View Post
    Do you have the plastic battery cover installed between the battery and electrical box? Take a quick look at the wire harness running from the ebox to the front of the motor. Pull the plastic loom open and look at the wires for any sign of burning or charring.

    Pretty simple quick checks. I would look at it for you, but a bit too far away....
    Yes I have the battery cover installed. I'll take a quick look at the wire harness when I can. Still would like to find someone knowledgeable in my area. Thanks for your help.

  4. #4
    Anybody interesting in buying this thing? I can send pics and information.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris slt 750 no spark
    By sridd22 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-11-2013, 11:28 PM
  2. 94 Polaris SLT 750- No Electrical Power
    By policano in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-11-2012, 10:11 PM
  3. 1993 Polaris slt 750 no spark
    By Iam1hugeguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-05-2011, 12:23 AM
  4. Polaris slt 750 no fire
    By tmintz5 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-22-2009, 09:26 PM
  5. 95 polaris slt 750 no spark
    By The Joker in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 11-20-2006, 06:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •