Results 1 to 2 of 2

Thread: Zxi 750 fuel

  1. #1

    Arrow Zxi 750 fuel

    Ok guys i have a 97 zxi 750, the issue I'm having is ill be riding for about 20 min and the ski dies. Cranks with no start. Upon inspection I noticed the pulse line came off the intake. So I reattached it and went about my day. For about 20 min it was fine and the same issue returned, pulse line was off. Now I noticed the forward cylinder was backfiring in the intake (this happens to be the cylinder the pulse line comes out of). My guess would be the reed valves need to be replaced, would this cause my issue?

  2. #2
    Lightning1's Avatar
    Join Date
    Mar 2013
    If you are backfiring into your intake, I would say you have a cracked or worn reed valve. This is the case with my snowmobiles anyways.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Look at this stator kawi zxi 750 *damage*
    By TX21 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 03-19-2008, 07:43 AM
  2. SLT 750 fuel tank in a '92 sl 650??
    By workaholic in forum Polaris Projects
    Replies: 3
    Last Post: 07-22-2007, 08:42 PM
  3. 94 slt 750 fuel question
    By ace16a in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-08-2007, 11:10 PM
  4. Sl 750 Fuel Problems....still
    By Polaaron in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-06-2007, 09:08 PM
  5. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts