Results 1 to 2 of 2

Thread: Stator fault?

  1. #1

    Stator fault?


    I had an electrical problem on my Seadoo RX DI, the battery would not charge and the ski kept going into limp mode. The battery is brand new so had a look at the forum and found that it can be the stator or regulator.

    I did the tests on the regulator, battery did not go past 12.5V and when reed up the voltage dropped so found that it is faulty so I replaced the regulator. Whilst doing this I also tested the stator.

    There was a connection problem at the plug on the stator cover which was easily resolved. When I tested the stator I got 0.5 resistance across the three yellows which is within spec and no continuity to ground. When I tested the Vac it got to 30Vac at 4000rpm across all three yellows. The manual says that you should get 40 - 70.

    Does this look like a stator problem or can it be something else like a connection? A stator just looks like a part to me that would not deteriorate in output but rather just fail? Am I wrong here and should I look at getting the stator replaced?

    Thanks for looking

  2. #2
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Bowling Green, KY
    30vac should be enough to charge, i suspect that your 4k rpm test wasn't 4k rpm... put it all together and see what the battery voltage comes up to when revving.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stator cooling mod
    By virageracer in forum Polaris PWC Performance
    Replies: 10
    Last Post: 12-19-2014, 01:17 PM
  2. Fault code P0336
    By terryt in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-13-2006, 08:44 PM
  3. Coinsidence or my fault?? Opinions needed desperately
    By Fuhreal in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 07-03-2006, 08:37 PM
  4. Stator Question on GP1200R
    By ramnj in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-17-2006, 11:51 AM
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 02-17-2006, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts