Results 1 to 7 of 7
  1. #1

    Join Date
    Apr 2015
    Location
    Long Island, N.Y (South Shore)
    Posts
    60
    +1
    3

    Flush connector just came loose..

    I was flushing my ski with a salt away attachment (no quick connect) once done, I started to unscrew the salt away adapter and then bam! then entire flush connector came loose..

    I tried putting it back, but it wont stay put in place.. this seems like the most simplest thing ever and I can't get it to stay!

    if not installed properly.. I'm assuming water will get in.

    http://imgur.com/a/DCK7N


    FIXED

    I didn't know that black thing acted as the nut but it's good now.
    Last edited by xewkija631; 05-15-2015 at 06:45 PM.


  2. #2
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    778
    In this case, you are lucky to have a RXT(X) because that is a real P.I.T.A to get to on a PX (to the back of the inside hull).

  3. #3
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    321
    Quote Originally Posted by Sanfish View Post
    In this case, you are lucky to have a RXT(X) because that is a real P.I.T.A to get to on a PX (to the back of the inside hull).

    x100000

  4. #4
    ride it like you stole it!!! raceneked's Avatar
    Join Date
    Sep 2011
    Location
    Lake Havasu, AZ
    Posts
    3,021
    +1
    840
    yeah, just had the drain-plug on my GTR come loose.

    Cant get it to tighten for sh*t.

    Naturally - it's the one BEHIND the iBR!!!

  5. #5

    Join Date
    Apr 2015
    Location
    Long Island, N.Y (South Shore)
    Posts
    60
    +1
    3
    Quote Originally Posted by raceneked View Post
    yeah, just had the drain-plug on my GTR come loose.

    Cant get it to tighten for sh*t.

    Naturally - it's the one BEHIND the iBR!!!


    That must be annoying! I'm assuming it's not the same flush as mine..? This simple thing took me like an hour plus to figure out! lol


    Also, should I run the ski on the hose too see if it leaks any water? or is their some test I should to too make sure it's tight enough?

  6. #6
    ride it like you stole it!!! raceneked's Avatar
    Join Date
    Sep 2011
    Location
    Lake Havasu, AZ
    Posts
    3,021
    +1
    840
    Its the circled fitting in my GTR...
    Click image for larger version. 

Name:	VCPDnuy.jpg 
Views:	60 
Size:	79.0 KB 
ID:	359296

  7. #7
    I had the same thing happen on my GTI...I just took the waterbox out, cleaned out the hole, put a thin coating of silicon around it, then tightened it back up. I had my head and shoulder in the hull and tightened the internal nut up by hand then had my buddy use the 3/8 ratchet to tighten from the outside as I use a torx head screwdriver in the slot so it wouldn't spin from inside as he cranked down from the outside. Honestly only took a little over an hour start to finish. But you definitely need a second set of hands to help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 GTI flush cap came loose
    By charger35v6 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-12-2015, 03:36 PM
  2. 2014 Sea DOO RXP X 260 FLUSH CONNECTOR LOOSE? HELP
    By dshahzad91 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-20-2014, 11:55 PM
  3. Just came in..
    By dereksabolracing in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-14-2007, 03:08 PM
  4. 2006 RXP Qick Flush Connector ????
    By Tiburon in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-26-2006, 04:21 PM
  5. YES! Fed-Ex just came with SOME of the goodies
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-26-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •