Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Oil everywhere, looks like its coming from the carbon seal (driveshaft)

    Hi. Was out on my 2004 rxp for the first time today and she stalled out and had the oil light and check engine light come on. After looking under the seat there was oil everywhere. Once I got here on land and open her up I could see oil coming out were the carbon ring (seal) is at. It drained most of the oil out of her. Is this the carbon seal or something else's. what do I do. Do you think I hurt the engine in anyway.


  2. #2
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    245
    +1
    35
    Sounds like the rear seal off the engine. To check, Remove the intake hose off the supercharger(helps to see down near the rear seal) and top it up with oil. Shine a light down towards were the shaft runs into the bellow(rubber boot) and quickly fire it up and check to see if oil leaks from there. You will see it leaking if it does.

    Good luck..

  3. #3
    It is, is this bad or a big job

  4. #4
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,535
    +1
    777
    Not the carbon ring.

    This is the PTO seal assembly that has popped out of the rubber boot. If you look/feel between carbon seal and PTO cover, you may see a clamp that broke or came off.

    The ideal solution is to remove driveshaft so you can properly put back the PTO bearing back into the rubber boot. You will either need a 48.5mm Oetiker clamp or narrow (9mm wide), high quality hose clamp.

    This recently happened to mine. However, I only lost 1 to 1.5qts of oil and the oil light never came on. If your oil light came out, you lost more than 2qts of oil. Hope you didn't ride it long when you saw the light come on.

    ps. Suck the oil out of engine and see how many quarts you get. As a reference, I pull 4qts of oil out of my ski when changing oil - with normal levels.

  5. #5
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    245
    +1
    35
    Quote Originally Posted by Sanfish View Post
    Not the carbon ring.

    This is the PTO seal assembly that has popped out of the rubber boot. If you look/feel between carbon seal and PTO cover, you may see a clamp that broke or came off.

    The ideal solution is to remove driveshaft so you can properly put back the PTO bearing back into the rubber boot. You will either need a 48.5mm Oetiker clamp or narrow (9mm wide), high quality hose clamp.

    This recently happened to mine. However, I only lost 1 to 1.5qts of oil and the oil light never came on. If your oil light came out, you lost more than 2qts of oil. Hope you didn't ride it long when you saw the light come on.

    ps. Suck the oil out of engine and see how many quarts you get.
    Thats exactly what happened to mine. Not a big job to fix but you will have to remove the shaft thou.

  6. #6
    No not long at all I hope 1min to the shore, I wasn't far. Do I need this carbon ring tool to do this job

  7. #7
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    245
    +1
    35
    Now thats debatable.lol
    You will need a tool to remove the c clip to remove the shaft.

  8. #8
    Any other parts I should replace why I'm in there. Carbon ring ect... And is it a seal I have to replace or just put back in and add a new clamp

  9. #9
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    You could also put some rv sealant in the boot where the bearing goes to help out as well. To get the c clip off take off pump and install a socket like a 14mm put pump back on with two bolts and slowly tighten a little bit. This will help you a bit getting that c clip out and again do not tighten all the way and use only two bolts.In addition spray the collar with some pb blaster or wd-40 to help get her loose.

  10. #10
    Thanks guys, you are all wicked.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in oil, where's it coming from? GTX 185hp
    By Az-Condor in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-26-2016, 06:57 PM
  2. For those that ever wondered what the older sho oil cooler looks like on the inside
    By bscpaint in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-07-2016, 08:41 AM
  3. Water in the hull...where is it coming from?
    By kepneriphone in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-16-2013, 10:04 PM
  4. Too much oil - where did it come from?
    By RightOnTarget1 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-08-2010, 09:47 PM
  5. Does this look like it should?
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-07-2007, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •